Bug 1476198 - [trello zoxUAO2w] The displays of pod's terminal is very abnormal
[trello zoxUAO2w] The displays of pod's terminal is very abnormal
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.7.0
Unspecified Unspecified
high Severity high
: ---
: 3.7.0
Assigned To: Samuel Padgett
XiaochuanWang
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-28 05:16 EDT by shahan
Modified: 2017-09-26 07:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-26 07:42:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blank (43.11 KB, image/png)
2017-07-28 05:18 EDT, shahan
no flags Details
smaller (19.96 KB, image/png)
2017-07-28 05:20 EDT, shahan
no flags Details

  None (edit)
Description shahan 2017-07-28 05:16:42 EDT
Description of problem:
  The displays of  pod's  terminal  is very abnormal

Version-Release number of selected component (if applicable):
  OpenShift Master:v3.6.0-rc.0+a17fa87-306
  Kubernetes Master:v1.7.0+695f48a16f 

How reproducible:
  Always

Steps to Reproduce:
1. oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/pods/pod_with_two_containers.json
2.Go to Browse-> Pods page, select 'doublecontainers' pod and switch to its "Terminal" tab
3.Check 'hello-openshift' container
4.Check 'hello-openshift-fedora' container

Actual results:
3. fresh page, will see the abnormal and smaller terminal.(see attachment)
4. the container's terminal displays as blank and cannot input any command (see attachment)

Expected results:
All steps should display normally.

Additional info:
Comment 1 shahan 2017-07-28 05:18 EDT
Created attachment 1305849 [details]
blank
Comment 2 shahan 2017-07-28 05:20 EDT
Created attachment 1305850 [details]
smaller
Comment 3 Samuel Padgett 2017-07-28 13:38:50 EDT
Upstream container-terminal PR:

https://github.com/kubernetes-ui/container-terminal/pull/28
Comment 4 Samuel Padgett 2017-07-28 13:39:14 EDT
This is only a problem in 3.7 with the xterm.js changes. It is not a problem in 3.6.
Comment 5 Samuel Padgett 2017-08-01 12:37:17 EDT
Console PR:

https://github.com/openshift/origin-web-console/pull/1897
Comment 7 shahan 2017-08-04 00:51:44 EDT
Checked these two issues with all kinds of browsers on the origin env which have merged the bug's PR, for the terminal displays as blank issue, it works on all browsers. But the terminal still becomes smaller size when fresh pod's terminal page and it is only normal in Firefox.
Comment 8 shahan 2017-08-04 02:53:46 EDT
sorry, the Firefox can also reproduce the smaller size terminal issue.
Comment 9 Samuel Padgett 2017-09-12 09:48:17 EDT
I'm not able to reproduce the smaller terminal issue in any browser. Are you still seeing it?
Comment 10 shahan 2017-09-13 03:33:54 EDT
I also cannot reproduce it:( Maybe this smaller terminal issue has been fixed by other PRs.
Comment 11 Xingxing Xia 2017-09-20 04:28:18 EDT
Checked in v3.7.0-0.126.4 per comment 0 steps. The problem is gone. Terminal works well in refresh and container switch.
Sam, please help move to ON_QA if no other concern, thx
Comment 13 XiaochuanWang 2017-09-26 04:34:58 EDT
Verified on latest OCP:
OpenShift Master:     v3.7.0-0.127.0
Kubernetes Master:    v1.7.0+80709908fd 

Container terminal and container drop-down select list display normal.

Note You need to log in before you can comment on or make changes to this bug.