Bug 147622 - Pyzor fails to build on x86_64
Summary: Pyzor fails to build on x86_64
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pyzor   
(Show other bugs)
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-09 21:22 UTC by Toshio Kuratomi
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 03:10:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix building on x86_64 (3.98 KB, patch)
2005-02-09 21:27 UTC, Toshio Kuratomi
no flags Details | Diff

Description Toshio Kuratomi 2005-02-09 21:22:07 UTC
Description of problem:
pyzor fails to build on x86_64.  This is due to the use of %{_libdir} in the
files section which searches for the installed files under /usr/lib64 on x86_64.
 because the files are arch independent python files, they are installed under
/usr/lib on multilib.  Using the latest macros from fedora-rpmdevtools
spectemplate.python fixes this.

Version-Release number of selected component (if applicable):
pyzor-0.4.0-6

How reproducible:
Always

Steps to Reproduce:
1. On an x86_64 computer, rombuild -ba pyzor.spec
2.
3.
  
Actual results:
See buildlog:
http://fedoraproject.org/extras/3/build-logs/x86_64/pyzor.log

Expected results:
Produce an rpm package file.

Additional info:

Comment 1 Toshio Kuratomi 2005-02-09 21:27:06 UTC
Created attachment 110896 [details]
Patch to fix building on x86_64

This patch updates the python macros to what's in fedora-rpmdevtools-0.3.0-1. 
They resolve the build problem by using the python_sitearch macro instead of
_libdir.  This patch is slightly different than the version tested by Aurelian
Bompard [1]_ as I also ghosted the pyzor .pyo files.

[1]_:
https://www.redhat.com/archives/fedora-extras-list/2005-February/msg00188.html

Comment 2 Warren Togami 2005-02-10 03:10:42 UTC
Thanks Toshio.  Lately I've seriously been considering sponsoring you.
 Keep it up.



Note You need to log in before you can comment on or make changes to this bug.