Bug 147626 - python-dialog does not build on x86_64
Summary: python-dialog does not build on x86_64
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-dialog   
(Show other bugs)
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-09 21:42 UTC by Toshio Kuratomi
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 18:37:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix building on x86_64 (1.13 KB, patch)
2005-02-09 21:47 UTC, Toshio Kuratomi
no flags Details | Diff

Description Toshio Kuratomi 2005-02-09 21:42:14 UTC
Description of problem:
On x86_64, %{_libdir} expands to /usr/lib64/.  Since the python files in
python-dialog are arch independent they install under /usr/lib.  Updating to the
latest fedora-rpmdevtools spectemplate.python macros solves the problem

Version-Release number of selected component (if applicable):

python-dialog-2.0.6-1
How reproducible:
Always

Steps to Reproduce:
1. on x86_64 machine, rpmbuild -ba python-dialog.spec
2.
3.
  
Actual results:
See: http://www.fedoraproject.org/extras/3/build-logs/x86_64/python-dialog.log

Expected results:
Produce and rpm package file.

Additional info:

Comment 1 Toshio Kuratomi 2005-02-09 21:47:06 UTC
Created attachment 110897 [details]
Patch to fix building on x86_64

Howdy Aurélien,  here's the patch between the new spec and the CVS version. 
You may already be working on this but I'm a compulsive paper shuffler
^H^H^Hgood bugzilla boy so I'm filing the bug report anyhow :-)

Comment 2 Aurelien Bompard 2005-02-10 18:37:09 UTC
Applied to CVS, thanks a lot. I will request a build.


Note You need to log in before you can comment on or make changes to this bug.