Bug 1476265 - The engine VM could not be registered to foreman/satellite from the engine
The engine VM could not be registered to foreman/satellite from the engine
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine (Show other bugs)
4.1.3.5
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.1.6
: 4.1.6.2
Assigned To: Andrej Krejcir
Artyom
: Triaged
Depends On:
Blocks: 1484582
  Show dependency treegraph
 
Reported: 2017-07-28 08:55 EDT by Simone Tiraboschi
Modified: 2017-09-19 06:01 EDT (History)
7 users (show)

See Also:
Fixed In Version: ovirt-engine-4.1.6.2
Doc Type: Bug Fix
Doc Text:
Cause: It was not allowed to set an external provider for the hosted engine VM. Consequence: The hosted engine VM could not be managed by foreman/satellite. Fix: Allow setting the external provider for the hosted engine VM. Result: Hosted engine VM can now be managed by foreman/satellite.
Story Points: ---
Clone Of:
: 1484582 (view as bug list)
Environment:
Last Closed: 2017-09-19 06:01:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: ovirt‑4.2+
mgoldboi: planning_ack+
msivak: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80980 master MERGED core: Allow changing external provider on the hosted engine VM 2017-08-30 09:31 EDT
oVirt gerrit 81214 ovirt-engine-4.1 MERGED core: Allow changing external provider on the hosted engine VM 2017-08-30 11:07 EDT

  None (edit)
Description Simone Tiraboschi 2017-07-28 08:55:56 EDT
Description of problem:
Trying to edit the engine VM from the engine in order to choose an external provider in the foreman/satellite sub-tab will lead to an error:
  There was an attempt to change Hosted Engine VM values that are locked.

The user can instead directly register the engine VM to foreman/satellite from shell.

Version-Release number of selected component (if applicable):
engine 4.1.3

How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine and wait for the engine to import the engine VM
2. add your foreman/satellite as an external provider
3. try to edit the engine VM to attach it to foreman/satellite

Actual results:
  There was an attempt to change Hosted Engine VM values that are locked.

Expected results:
It attaches the engine VM to foreman/satellite

Additional info:
Comment 1 Doron Fediuck 2017-07-30 04:40:16 EDT
Care to attach the engine log?
Comment 3 Doron Fediuck 2017-08-09 08:51:46 EDT
Artyom can you reproduce this issue?
Comment 4 Artyom 2017-08-09 11:02:29 EDT
I just do not have an instance of foreman that configured as ovirt external provider, I will check among QE guys, maybe someone has one. But anyway it will take me sometime.
Comment 5 Artyom 2017-08-10 04:05:45 EDT
I found the satellite environment.

Steps:
1. Add satellite as external provider
2. Under Edit VM -> Foreman/Satellite -> Under provider choose you provider by name -> Ok

"""
Error while executing action: 

HostedEngine:
There was an attempt to change Hosted Engine VM values that are locked.
"""

Versions:
rhevm-4.1.4.2-0.1.el7.noarch
satellite-6.2.8-4.0.el7sat.noarch
Comment 6 rhev-integ 2017-08-31 12:51:35 EDT
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Tag 'ovirt-engine-4.1.6.1' doesn't contain patch 'https://gerrit.ovirt.org/81214']
gitweb: https://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=shortlog;h=refs/tags/ovirt-engine-4.1.6.1

For more info please contact: infra@ovirt.org
Comment 7 Artyom 2017-09-07 08:41:21 EDT
Verified on rhevm-4.1.6.2-0.1.el7.noarch

Note You need to log in before you can comment on or make changes to this bug.