Bug 1476293 - [RFE] Configure BMaaS to boot instances from cinder volumes
[RFE] Configure BMaaS to boot instances from cinder volumes
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity medium
: Upstream M1
: 13.0 (Queens)
Assigned To: RHOS Maint
mlammon
http://specs.openstack.org/openstack/...
: FutureFeature, TechPreview, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-28 10:21 EDT by Derek Higgins
Modified: 2018-06-27 09:34 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-ironic-10.0.1-0.20180123173432.2c630d9.el7ost.noarch
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-27 09:33:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 512662 None None None 2018-03-02 05:31 EST
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 09:34 EDT

  None (edit)
Description Derek Higgins 2017-07-28 10:21:19 EDT
Boot from volume has recently been added to Ironic upstream. Now that it has
ironic if deployed in the overcloud should be capable of booting baremetal instances from images on cinder volumes.
Comment 3 Dmitry Tantsur 2017-10-02 07:07:50 EDT
The ironic part is done, and the THT part might be done already too. Needs testing from dev before handing to qe.
Comment 4 Derek Higgins 2017-10-26 01:44:34 EDT
Upstream testing done, boot from cinder volume in the tripleo overcloud is working over iscsi. One bug found and fixed
https://review.openstack.org/#/c/512662/

The image being used must be setup to use BFV, for the CentOS cloud image this means two things

The kernel must be booted with rd.iscsi.firmware=1 so that iscsi target details are read from the firmware (passed to it by ipxe), this needs to be added to the grub config

The ramdisk in the image needs to have the iscsi dracut module in it, this is achieved by installing “iscsi-initiator-utils” in the image then adding the network and iscsi modules to the ramdisk
$ RAMDISK=/boot/initramfs-3.10.0-693.el7.x86_64.img
$ KERNEL_VERSION=3.10.0-693.el7.x86_64
$ dracut --force --add "network iscsi" $RAMDISK $KERNEL_VERSION

Both of these can be achieved by using guestmount (or similar) and making the required changes in a chroot.
Comment 6 Ramon Acedo 2017-10-26 05:33:01 EDT
Many thanks Derek! We'd need to make sure that the RHEL KVM Guest Image [1], which is a whole-disk image. Would this be possible to test with? Mainly because we should have it documented downstream for the RHEL KVM Guest Image (ideally upstream with RHEL and CentOS and other flavours).

Derek, is this ready to QA? It looks like it can go to POST if all the patches are finished, right?

[1] https://access.redhat.com/downloads/content/69/ver=/rhel---7/7.4/x86_64/product-software
Comment 8 Derek Higgins 2017-10-26 12:14:46 EDT
(In reply to Ramon Acedo from comment #6)
> Many thanks Derek! We'd need to make sure that the RHEL KVM Guest Image [1],
> which is a whole-disk image. Would this be possible to test with? Mainly
> because we should have it documented downstream for the RHEL KVM Guest Image
> (ideally upstream with RHEL and CentOS and other flavours).
> 
> Derek, is this ready to QA? It looks like it can go to POST if all the
> patches are finished, right?
> 
> [1]
> https://access.redhat.com/downloads/content/69/ver=/rhel---7/7.4/x86_64/
> product-software

Also note that adding rd.iscsi.firmware=1 to the kernel params currently means that the image can't be used for localboot, so as is we would need an iscsi image and a separate localboot image. I have submitted a fix to dracut so they can be common https://github.com/dracutdevs/dracut/pull/298
we should then be able to create a image that can do both bfv and localboot.

images problems aside, we also need to figure out a solution for the metadata service which doesn't seem to be working for ironic in the overcloud. This wasn't needed up to now as config drive was used but config drive isn't a thing in BFV. I'm looking into this now.
Comment 9 Derek Higgins 2017-11-15 12:44:16 EST
bug for dracut reported here, it shouldn't stall this bugs as its not about support in tripleo
   https://bugzilla.redhat.com/show_bug.cgi?id=1513397

the metadata service works once a router is created and the provisioning subnet is attache to it. All is working upstream.
Comment 13 Bob Fournier 2018-03-01 15:06:47 EST
Derek - can you set the Fixed in Version with the rpm's that this fix is in? I would, but not sure what they are.
Comment 14 Derek Higgins 2018-03-02 05:31:18 EST
(In reply to Bob Fournier from comment #13)
> Derek - can you set the Fixed in Version with the rpm's that this fix is in?
> I would, but not sure what they are.

Setting, Switching component to openstack-ironic and linking to the required ironic fix.
Comment 18 errata-xmlrpc 2018-06-27 09:33:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086

Note You need to log in before you can comment on or make changes to this bug.