Bug 1476306 - /usr/libexec/glib-pacrunner coredump
/usr/libexec/glib-pacrunner coredump
Status: CLOSED DUPLICATE of bug 1459779
Product: Fedora
Classification: Fedora
Component: glib-networking (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-28 11:07 EDT by H.J. Lu
Modified: 2017-08-17 06:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 08:13:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2017-07-28 11:07:20 EDT
/usr/libexec/glib-pacrunner dumps core from time to time:

# file core.18880
core.18880: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style, from '/usr/libexec/glib-pacrunner', real uid: 1000, effective uid: 1000, real gid: 1000, effective gid: 1000, execfn: '/usr/libexec/glib-pacrunner', platform: 'x86_64'
# gdb /usr/libexec/glib-pacrunner core.18880
Reading symbols from /usr/libexec/glib-pacrunner...Reading symbols from /usr/libexec/glib-pacrunner...(no debugging symbols found)...done.
(no debugging symbols found)...done.
[New LWP 2274]
[New LWP 19166]
[New LWP 19169]
[New LWP 19164]
[New LWP 19163]
[New LWP 18883]
[New LWP 18881]
[New LWP 19162]
[New LWP 19165]
[New LWP 19171]
[New LWP 19167]
[New LWP 19172]
[New LWP 19168]
[New LWP 18880]
[New LWP 19170]
[New LWP 19173]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `/usr/libexec/glib-pacrunner'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f29978a8240 in JS_AbortIfWrongThread(JSRuntime*) ()
   from /lib64/libmozjs-38.so
[Current thread is 1 (Thread 0x7f298ffff700 (LWP 2274))]
Missing separate debuginfos, use: dnf debuginfo-install glib-networking-2.50.0-2.fc26.x86_64
(gdb) disass
Dump of assembler code for function _Z21JS_AbortIfWrongThreadP9JSRuntime:
   0x00007f29978a8210 <+0>:	push   %rbp
   0x00007f29978a8211 <+1>:	mov    %rsp,%rbp
   0x00007f29978a8214 <+4>:	push   %rbx
   0x00007f29978a8215 <+5>:	mov    %rdi,%rbx
   0x00007f29978a8218 <+8>:	sub    $0x8,%rsp
   0x00007f29978a821c <+12>:	callq  0x7f29974a52a0 <_ZN2js29CurrentThreadCanAccessRuntimeEP9JSRuntime@plt>
   0x00007f29978a8221 <+17>:	test   %al,%al
   0x00007f29978a8223 <+19>:	je     0x7f29978a8240 <_Z21JS_AbortIfWrongThreadP9JSRuntime+48>
   0x00007f29978a8225 <+21>:	mov    0x234805(%rip),%edi        # 0x7f2997adca30
   0x00007f29978a822b <+27>:	callq  0x7f29974a5860 <pthread_getspecific@plt>
   0x00007f29978a8230 <+32>:	cmp    0x90(%rax),%rbx
   0x00007f29978a8237 <+39>:	jne    0x7f29978a8240 <_Z21JS_AbortIfWrongThreadP9JSRuntime+48>
   0x00007f29978a8239 <+41>:	add    $0x8,%rsp
   0x00007f29978a823d <+45>:	pop    %rbx
   0x00007f29978a823e <+46>:	pop    %rbp
   0x00007f29978a823f <+47>:	retq   
=> 0x00007f29978a8240 <+48>:	movl   $0x0,0x0
   0x00007f29978a824b <+59>:	ud2    
---Type <return> to continue, or q <return> to quit---
(gdb) bt
#0  0x00007f29978a8240 in JS_AbortIfWrongThread(JSRuntime*) ()
    at /lib64/libmozjs-38.so
#1  0x00007f29978ab412 in js::DestroyContext(JSContext*, js::DestroyContextMode) () at /lib64/libmozjs-38.so
#2  0x00007f2997ae3cdf in mozjs_pacrunner::~mozjs_pacrunner() ()
    at /usr/lib64/libproxy/0.4.15/modules/pacrunner_mozjs.so
#3  0x00007f299a520848 in libproxy::pacrunner_extension::get(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, libproxy::url const&) () at /lib64/libproxy.so.1
#4  0x00007f299a524f1a in libproxy::proxy_factory::run_pac(libproxy::url&, libproxy::url const&, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&) () at /lib64/libproxy.so.1
#5  0x00007f299a525da2 in libproxy::proxy_factory::get_proxies(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >) ()
    at /lib64/libproxy.so.1
#6  0x00007f299a5261f2 in px_proxy_factory_get_proxies ()
    at /lib64/libproxy.so.1
#7  0x000000bfdcb509fd in get_libproxy_proxies ()
#8  0x00007f299ad26086 in g_task_thread_pool_thread ()
    at /lib64/libgio-2.0.so.0
#9  0x00007f299a7a8f00 in g_thread_pool_thread_proxy ()
    at /lib64/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#10 0x00007f299a7a8536 in g_thread_proxy () at /lib64/libglib-2.0.so.0
#11 0x00007f29996ac5bd in start_thread () at /lib64/libpthread.so.0
#12 0x00007f299a257edf in clone () at /lib64/libc.so.6
(gdb)
Comment 1 Dan Winship 2017-07-31 08:13:00 EDT

*** This bug has been marked as a duplicate of bug 1459779 ***

Note You need to log in before you can comment on or make changes to this bug.