Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1476322 - backup fails if changelog is enabled
backup fails if changelog is enabled
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Ludwig
Viktor Ashirov
Marc Muehlfeld
: ZStream
Depends On:
Blocks: 1479755
  Show dependency treegraph
 
Reported: 2017-07-28 11:52 EDT by Ludwig
Modified: 2018-04-10 10:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.7.5-4.el7
Doc Type: Bug Fix
Doc Text:
Backup now succeeds if replication was enabled and a changelog file existed Previously, if replication was enabled and a changelog file existed, performing a backup on this master server failed. This update sets the internal options for correctly copying a file. As a result, creating a backup now succeeds in the mentioned scenario.
Story Points: ---
Clone Of:
: 1479755 (view as bug list)
Environment:
Last Closed: 2018-04-10 10:19:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0811 None None None 2018-04-10 10:20 EDT

  None (edit)
Description Ludwig 2017-07-28 11:52:50 EDT
Description of problem:


If replication is enabled and a changelog is configured backup fails

 [28/Jul/2017:12:09:00.566037827 +0200] - ERR - dblayer_copy_directory - Backend instance "changelogdb" does not exist; Instance path /var/lib/dirsrv/slapd-s1/changelogdb could be invalid.
[28/Jul/2017:12:09:00.572168833 +0200] - ERR - dblayer_backup - Error in copying directory (/var/lib/dirsrv/slapd-s1/changelogdb -> /var/lib/dirsrv/slapd-s1/bak/s1-2017_07_28_12_08_59/.repl_changelog_backup): err=-1

and the backup is incomplete
Comment 2 Ludwig 2017-07-28 11:53:40 EDT
upstream ticket: #49334
Comment 5 Orion Poplawski 2017-08-28 12:21:40 EDT
I'm getting similar, but with a different db name:

[26/Aug/2017:03:00:21.233754356 -0600] - ERR - dblayer_copy_directory - Backend instance "cldb" does not exist; Instance path /var/lib/dirsrv/slapd-NWRA-COM/cldb could be invalid.
[26/Aug/2017:03:00:21.307454032 -0600] - ERR - dblayer_backup - Error in copying directory (/var/lib/dirsrv/slapd-NWRA-COM/cldb -> /var/lib/dirsrv/slapd-NWRA-COM/bak/NWRA-COM/.repl_changelog_backup): err=-1
Comment 7 ashiveka 2017-11-21 23:21:56 EST
    ============================================================================ test session starts ============================================================================
    platform linux -- Python 3.5.1, pytest-3.2.3, py-1.4.34, pluggy-0.4.0 -- /opt/rh/rh-python35/root/usr/bin/python3
    cachedir: .cache
    metadata: {'Python': '3.5.1', 'Packages': {'pytest': '3.2.3', 'pluggy': '0.4.0', 'py': '1.4.34'}, 'Platform': 'Linux-4.11.0-44.el7a.x86_64-x86_64-with-redhat-7.4-Maipo', 'Plugins': {'metadata': '1.5.0', 'html': '1.16.0'}}
    389-ds-base: 1.3.6.1-21.el7_4
    nss: 3.28.4-15.el7_4
    nspr: 4.13.1-1.0.el7_3
    openldap: 2.4.44-5.el7
    svrcore: 4.1.3-2.el7
     
    rootdir: /mnt/tests/rhds/tests/upstream, inifile:
    plugins: metadata-1.5.0, html-1.16.0
    collected 3 items                                                                                                                                                            
     
    ds/dirsrvtests/tests/suites/replication/changelog_test.py::test_verify_changelog PASSED
    ds/dirsrvtests/tests/suites/replication/changelog_test.py::test_verify_changelog_online_backup PASSED
    ds/dirsrvtests/tests/suites/replication/changelog_test.py::test_verify_changelog_offline_backup PASSED
     
    ========================================================================= 3 passed in 28.60 seconds =========================================================================
Comment 10 errata-xmlrpc 2018-04-10 10:19:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0811

Note You need to log in before you can comment on or make changes to this bug.