Bug 1476354 - "Error analyzing: path.to.module (SourceModule)" as java.lang.RuntimeException when loading pycodestyle
Summary: "Error analyzing: path.to.module (SourceModule)" as java.lang.RuntimeExceptio...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-pydev
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1496452 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-28 17:23 UTC by Christian Stadelmann
Modified: 2017-10-10 21:22 UTC (History)
4 users (show)

Fixed In Version: eclipse-pydev-5.9.2-2.fc27 eclipse-pydev-5.9.2-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-05 21:02:56 UTC
Type: Bug


Attachments (Terms of Use)
The problem directory under /var/spool/abrt/libreport-[date]-[time]-[pid] (2.74 KB, application/x-xz)
2017-07-28 17:23 UTC, Christian Stadelmann
no flags Details

Description Christian Stadelmann 2017-07-28 17:23:49 UTC
Created attachment 1306000 [details]
The problem directory under /var/spool/abrt/libreport-[date]-[time]-[pid]

Description of problem:


Version-Release number of selected component (if applicable):
python2-2.7.13-11.fc26.x86_64
python3-3.6.2-1.fc26.x86_64
python-pep8-1.6.2-8.fc26.noarch
python3-pep8-1.6.2-8.fc26.noarch
python3-pycodestyle-2.0.0-4.fc26.noarch
eclipse-pydev-5.8.0-1.fc26.x86_64
eclipse-swt-4.7.0-2.fc26.x86_64


How reproducible:
always when opening a PyDev project

Steps to Reproduce:
1. open Eclipse
2. open a PyDev project
3. watch the error messages

Actual results:
Backtrace:
java.lang.RuntimeException: Can't find relative path:pysrc/third_party/pep8/pycodestyle.py within:org.python.pydev_5.8.0.v20170616-0956 [576]
	at org.python.pydev.shared_core.bundle.BundleUtils.getRelative(BundleUtils.java:27)
	at org.python.pydev.shared_ui.bundle.BundleInfo.getRelativePath(BundleInfo.java:39)
	at org.python.pydev.plugin.PydevPlugin.getScriptWithinPySrc(PydevPlugin.java:377)
	at org.python.pydev.plugin.JythonModules.getPepModuleLocation(JythonModules.java:57)
	at org.python.pydev.plugin.JythonModules.getPep8Location(JythonModules.java:25)
	at org.python.pydev.builder.pep8.Pep8Visitor.getMessages(Pep8Visitor.java:99)
	at com.python.pydev.analysis.OccurrencesAnalyzer$1.run(OccurrencesAnalyzer.java:46)
Caused by: java.lang.NullPointerException
	at org.python.pydev.shared_core.bundle.BundleUtils.getRelative(BundleUtils.java:23)
	... 6 more

Expected results:
No crasher, but analyze code.

Additional info:
See attached abrt problem dir.

Comment 1 Mat Booth 2017-09-27 12:57:53 UTC
*** Bug 1496452 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2017-09-29 15:41:29 UTC
eclipse-pydev-5.9.2-2.fc26 jython-2.7.1-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-bcf6079c0c

Comment 3 Fedora Update System 2017-09-29 15:41:39 UTC
eclipse-pydev-5.9.2-2.fc27 jython-2.7.1-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1a9c26541b

Comment 4 Fedora Update System 2017-10-01 23:54:35 UTC
eclipse-pydev-5.9.2-2.fc26, jython-2.7.1-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-bcf6079c0c

Comment 5 Fedora Update System 2017-10-02 00:55:03 UTC
eclipse-pydev-5.9.2-2.fc27, jython-2.7.1-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1a9c26541b

Comment 6 Fedora Update System 2017-10-05 21:02:56 UTC
eclipse-pydev-5.9.2-2.fc27, jython-2.7.1-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2017-10-10 21:22:13 UTC
eclipse-pydev-5.9.2-2.fc26, jython-2.7.1-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.