Bug 1476381 - creating new authentication using REST API fails with undefined method `id' for nil:NilClass
creating new authentication using REST API fails with undefined method `id' f...
Status: CLOSED DUPLICATE of bug 1476327
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity medium
: GA
: cfme-future
Assigned To: James Wong
Martin Kourim
api:rest
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-28 14:47 EDT by Martin Kourim
Modified: 2017-11-07 09:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-07 09:39:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kourim 2017-07-28 14:47:40 EDT
Description of problem:
When creating authentications using /api/authentications the action fails with undefined method `id' for nil:NilClass


Version-Release number of selected component (if applicable):
5.8.1.5


How reproducible:
very


Steps to Reproduce:
1.
POST /api/authentications
{
  "description" : "Authentication Description1",
  "name" : "SomeCredentials1",
  "related" : {},
  "type" : "ManageIQ::Providers::AnsibleTower::AutomationManager::Credential",
  "manager_resource" : { "href" : "https://<address>/api/providers/:id_of_ansible_provider" }
}
2. check corresponding task


Actual results:
{
...
    "name": "Creating Ansible Tower Credential (name=SomeCredentials1)",
    "state": "Finished",
    "status": "Error",
    "message": "undefined method `id' for nil:NilClass",
    "userid": "system",
...
}


Expected results:
Authentication is created
Comment 3 Jillian Tullo 2017-10-16 14:05:55 EDT
Assigning to James as he knows the issue behind this error.
Comment 4 James Wong 2017-11-07 09:39:41 EST

*** This bug has been marked as a duplicate of bug 1476327 ***
Comment 5 James Wong 2017-11-07 09:41:04 EST
As discussed and with the agreement from Martin, I've closed this as duplicate and will provide fix in https://bugzilla.redhat.com/show_bug.cgi?id=1476327

Note You need to log in before you can comment on or make changes to this bug.