Bug 1476407 - "xfce4-terminal --tab" does nothing if a window is already open
"xfce4-terminal --tab" does nothing if a window is already open
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-terminal (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-28 18:03 EDT by Lonni J Friedman
Modified: 2017-08-09 15:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: xfce4-terminal-0.8.6-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 15:58:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lonni J Friedman 2017-07-28 18:03:21 EDT
Description of problem:

Since upgrading from Fedora24 to 25 (now running xfce4-terminal-0.8.5.1-1.fc25.x86_64), the --tab option no longer works if I already have a pre-existing xfce4-terminal window open.  

Version-Release number of selected component (if applicable):
xfce4-terminal-0.8.5.1-1.fc25.x86_64

How reproducible:
100% of the time

Steps to Reproduce:
1.Run 'xfce4-terminal --tab'
2.
3.

Actual results:
Nothing happens

Expected results:
A new tab is created in the pre-existing xfce4-terminal window, or a new window is opened

Additional info:
[netllama@netllama ~]$ xfce4-terminal --tab
[netllama@netllama ~]$ echo $?
0
Comment 1 Kevin Fenzi 2017-07-28 18:34:24 EDT
This is fixed in 0.8.6 I am pretty sure. 

I didn't build that version for f25, but I can/should... look for an update to test out in a few.
Comment 2 Fedora Update System 2017-07-28 18:55:45 EDT
xfce4-terminal-0.8.6-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8ccbc1137b
Comment 3 Fedora Update System 2017-07-30 22:21:58 EDT
xfce4-terminal-0.8.6-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8ccbc1137b
Comment 4 Lonni J Friedman 2017-07-31 11:18:52 EDT
I can confirm that the build in testing resolves this bug.  thanks!
Comment 5 Fedora Update System 2017-08-09 15:58:18 EDT
xfce4-terminal-0.8.6-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.