Bug 147649 - Asus P4P800-VM X-windows becomes unstable with 2 DIMMs installed
Asus P4P800-VM X-windows becomes unstable with 2 DIMMs installed
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-09 20:32 EST by Philip Edelbrock
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 11:27:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Edelbrock 2005-02-09 20:32:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
After trial and error, I realized that X will become unstable and crash the computer after a while (during a normal day's use) if I have 2 DIMMs installed.  memtest86 says that memory is good.  Others on x.org have reported similar, but it hasn't been obvious that the DIMM configuration makes an impact until recently.

Bios version is the latest (1014).  I've swapped DIMMs to make sure one isn't bad. (Still testing, but so far so good.)

My baseline test is to use the screensaver XFlame and let the computer sit overnight.  It has never survived the night without being frozen in the morning if both DIMMs are installed.  Choosing 'blank screen' instead of a screen saver seems to avoid the problem, so that's why I list this as a problem in the xorg-x11 package.  However, crashes and stability problems arise during normal interactive use, even if 'blank screen' is selected.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.21

How reproducible:
Always

Steps to Reproduce:
1.Install 2 Asus 'qualified' DIMMS in Dual-channel configuration (I'm using two Transcend 512MB DIMMs)
2.Boot the machine normally into X
3.Choose the XFlame screensaver, perhaps launch a few apps (like Mozilla)
4.Let the screen saver sit overnight


Actual Results:  Computer frozen by morning.  During normal use, apps may segfault, X may restart spotaniously, the kernel may panic (keyboard lights blinking), computer locks up hard, etc.  Most evident during clicks, scrolling, workspace changes, etc.

Expected Results:  No crashes, panics, unusual app failures, etc.

Additional info:

The top of /var/log/Xorg.0.log says:

X Window System Version 6.8.1
Release Date: 17 September 2004
X Protocol Version 11, Revision 0, Release 6.8.1
Build Operating System: Linux 2.6.9-1.751_ELsmp i686 [ELF] 
Current Operating System: Linux DrTheopolis.netroedge.com 2.6.10-1.760_FC3smp #1 SMP Wed Feb 2 00:29:03 EST 2005 i686
Build Date: 01 December 2004
Build Host: tweety.build.redhat.com

Module Loader present
OS Kernel: Linux version 2.6.10-1.760_FC3smp (bhcompile@bugs.build.redhat.com) (gcc version 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)) #1 SMP Wed Feb 2 00:29:03 EST 
2005 

Also, see the related x.org bugzilla entry:

https://bugs.freedesktop.org/show_bug.cgi?id=1771

And, (marked as dup):

https://bugs.freedesktop.org/show_bug.cgi?id=2136
Comment 1 Mike A. Harris 2005-02-11 11:27:58 EST
Thanks for your report, and the upstream bug URL.  We will add this
to our upstream issue tracker, and track the issue in the X.Org
bug report.  Once the problem is resolved and fixes are available,
we will review them for consideration in future updates.

Setting status to "UPSTREAM" for tracking.

Note You need to log in before you can comment on or make changes to this bug.