Bug 1476503 - AppStream metadata for Wireshark package are missing [NEEDINFO]
AppStream metadata for Wireshark package are missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
27
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-29 13:15 EDT by AsciiWolf
Modified: 2017-11-21 05:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-21 05:45:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
msehnout: needinfo? (rhughes)


Attachments (Terms of Use)

  None (edit)
Description AsciiWolf 2017-07-29 13:15:30 EDT
Description of problem:

There is not any appdata.xml/metainfo.xml file available in the Wireshark package. Because of this, Wireshark cannot be found and/or installed using the GNOME Software application or another package manager UI based on AppStream.


Steps to Reproduce:

1. Open GNOME Software.
2. Type "wireshark".
Comment 1 Martin Sehnoutka 2017-07-31 07:47:49 EDT
Hi,

the package "wireshark" itself is just a metapackage for Wireshark GTK and Wireshark Qt versions. Looking at the last Koji build, I can see appdata.xml in place:
https://koji.fedoraproject.org/koji/rpminfo?rpmID=10468592

Are you sure, that this is the root cause of this bug?
Comment 2 AsciiWolf 2017-07-31 07:58:24 EDT
Oops, I have overlooked that. Anyway, Wireshark is missing in GNOME Software. I am not sure what causes the issue.
Comment 3 Martin Sehnoutka 2017-08-01 08:14:39 EDT
I'm not familiar with gnome software, but there is definitely a regression. I think it could be caused by this commit, but I'm not sure, what is wrong with the new appdata file:
http://pkgs.fedoraproject.org/cgit/rpms/wireshark.git/commit/?id=f3bc808c5bd7c26fe3b29fda5da3d97897cff37a

Richard, can you help me with this?
Comment 4 Jan Kurik 2017-08-15 02:32:53 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 5 AsciiWolf 2017-11-21 05:45:43 EST
This issue has been fixed in Fedora 27.

Note You need to log in before you can comment on or make changes to this bug.