Bug 1476557 - System becomes unusable after VM_BUG_ON_PAGE(page_ref_count(page) == 0) [NEEDINFO]
System becomes unusable after VM_BUG_ON_PAGE(page_ref_count(page) == 0)
Status: NEW
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
26
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-30 06:02 EDT by Wolfgang Denk
Modified: 2018-02-27 22:39 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
labbott: needinfo? (wd)


Attachments (Terms of Use)
syslog entry for kernel BUG (4.15 KB, text/plain)
2017-07-30 06:02 EDT, Wolfgang Denk
no flags Details

  None (edit)
Description Wolfgang Denk 2017-07-30 06:02:45 EDT
Created attachment 1306542 [details]
syslog entry for kernel BUG

Description of problem:

After upgrading from Fedora 25 (which worked fine) to Fedora 26, The following happens:
- System starts without obvious problems
- Desktop environment (FVWM) starts without obvious problems
- everything appears to be working fine
- when I try to start firefox, I get the following messages on the console:

Message from syslogd@nyx at Jul 30 11:40:10 ...
 kernel:page:fffff5c5061e2600 count:0 mapcount:-127 mapping:          (null) index:0x0

Message from syslogd@nyx at Jul 30 11:40:10 ...
 kernel:flags: 0x17ffffc0000000()

...and firefox does not come up.
The syslog contains an error entry (see attachment):
Jul 30 11:40:10 nyx kernel: page:fffff5c5061e2600 count:0 mapcount:-127 mapping:          (null) index:0x0
Jul 30 11:40:10 nyx kernel: flags: 0x17ffffc0000000()
Jul 30 11:40:10 nyx kernel: raw: 0017ffffc0000000 0000000000000000 0000000000000000 00000000ffffff80
Jul 30 11:40:10 nyx kernel: raw: fffff5c507670020 ffff9b061ffd1ef8 0000000000000003 0000000000000000
Jul 30 11:40:10 nyx kernel: page dumped because: VM_BUG_ON_PAGE(page_ref_count(page) == 0)
Jul 30 11:40:10 nyx kernel: ------------[ cut here ]------------
Jul 30 11:40:10 nyx kernel: kernel BUG at ./include/linux/mm.h:462!
Jul 30 11:40:10 nyx kernel: invalid opcode: 0000 [#2] SMP

- From then, all attempts to access the filesystem (i. e. a simple "ls /"
will hang permanently in uninterruptable sleep ('D' in ps).
- in 4 out of 5 attepmts this happened while firefox was starting, before any window was displayed.
- in one attempt firefox came up, but the same error happened when I tried to open a web page.

Running another kernel in the same installation works fine (kernel-4.11.12-200.fc25.x86_64 - i. e. basically same kernel version, but previous fedora release)

Version-Release number of selected component (if applicable):

kernel-4.11.12-100.fc24.x86_64



How reproducible:

Always


Steps to Reproduce:
1. Boot the system
2. Login
3. start firefox

Actual results:

Kernel Bug, system becomes unusable

Expected results:

no bug

Additional info: see attachment for full syslog entry
Comment 1 Laura Abbott 2018-02-27 22:39:56 EST
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.

Note You need to log in before you can comment on or make changes to this bug.