Bug 1476581 - Flash-Plugin not working properly
Flash-Plugin not working properly
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
26
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-30 08:48 EDT by thomas meiner
Modified: 2017-08-01 07:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 07:34:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thomas meiner 2017-07-30 08:48:05 EDT
Description of problem:
The Adobe Flash-Plugin in Firefox loads but isn't working properly. Chromium showes the exactly same behaver. Some Pages won't load Flash contents. It's e.g. the case for the TV-Web-Clinet of wilmaa.com. Other online TV-portals show similar behaviour.

With the exactly same versions of Firebox, Chromium and Flash it works well in Fedora 24. Because of this it looks like a problem in the Fedora 26 packages of Firefox, Chromium or in a dispense of the Flash-Plugin. 

There are no helpful dumps of Firefox. 


Version-Release number of selected component (if applicable):
Not working, f26:
firefox.x86_64 54.0-2.fc26 
chromium.x86_64 59.0.3071.115-3.fc26
flash-plugin.x86_64 26.0.0.137
flash-player-ppapi.x86_64 26.0.0.137

Working well, f24:
firefox.x86_64 54.0-2.fc24
chromium.x86_64 59.0.3071.104-1.fc24
flash-player-ppapi.x86_64 26.0.0.137
flash-plugin.x86_64 26.0.0.137

the Flash-Plugins are installed by dnf from Adobes own repository on http://linuxdownload.adobe.com


How reproducible: 100%


Steps to Reproduce:
1. rpm -ivh http://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm
2. rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux
3. dnf install -y firefox chromium flash-player-ppapi flash-plugin
4. start Firefox or Chromium
5. Navigate to https://app.wilmaa.com
6. May allow wilmaa to use Flash
7. Login to wilmaa
8a. Now will wilmaa load for ever in fedora 26... Firefox doesn't output any errors.
8b. On fedora 24 you'll be watching TV after a few seconds...


Actual results: Flash isn't working properly


Expected results: Same behaviour as in Fedora 24


Additional info:
Firefox shows the following errors:

thom@localhost ~ $ firefox
[GFX1-]: ClientLayerManager::BeginTransaction with IPC channel down. GPU process may have died.
[GFX1-]: ClientLayerManager::BeginTransaction with IPC channel down. GPU process may have died.
[GFX1-]: ClientLayerManager::BeginTransaction with IPC channel down. GPU process may have died.

###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0082,name=PBrowser::Msg_Destroy) Closed channel: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x2C0001,name=PBrowser::Msg_AsyncMessage) Closed channel: cannot send/recv
Comment 1 thomas meiner 2017-08-01 07:34:23 EDT
SOLVED! It was  a SELinux issue. The fix was easy:
  touch /.autorelabel
  reboot

Unfortunately I'm unable to tell which boolean caused the problem.

Note You need to log in before you can comment on or make changes to this bug.