This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 147665 - system randomly hangs when closing Xorg
system randomly hangs when closing Xorg
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 02:35 EST by Luis Marqueta
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 16:29:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X Configuration (3.00 KB, text/plain)
2005-02-12 02:53 EST, Luis Marqueta
no flags Details
last X log file (40.61 KB, text/plain)
2005-02-12 02:55 EST, Luis Marqueta
no flags Details
/var/log/messages (31.01 KB, text/plain)
2005-02-12 02:58 EST, Luis Marqueta
no flags Details

  None (edit)
Description Luis Marqueta 2005-02-10 02:35:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
System randomly hangs when shutting down X. Not always reproducible,
but the system freezes most of the times.

Version-Release number of selected component (if applicable):
xorg-x11-tools-6.8.1.12

How reproducible:
Sometimes

Steps to Reproduce:
1. Start X
2. Log out, shutdown, telinit 3 or ctr+alt+del


Actual Results:  2 out of 3 times the system will hang

Expected Results:  System not hanging

Additional info:

Commenting out the line 'Load  "glx"' in /etc/X11/xorg.conf the system
works as expected
Comment 1 Luis Marqueta 2005-02-10 02:43:06 EST
ATI Radeon Mobility 7500 on IBM ThinkPad R51
Comment 4 Mike A. Harris 2005-02-11 11:54:32 EST
Please attach your X server config file, log file, and
/var/log/messages files as individual uncompressed file attachments
using the bugzilla file attachment link below.

Once you've attached the files, we can review them to try and
determine if this is a new issue, or if it is a duplicate of
similar issues that have been reported.

There have been some similar bugs fixed in the xorg-x11-6.8.2
release, which will be part of the RHEL4 U1 update.  We will
be making some test packages available soon which you can try
in order to see if the new release resolves this issue.

I will add a new comment and URL to the rpms when they're ready
for testing.

Thanks for your report.

Comment 6 Luis Marqueta 2005-02-12 02:53:23 EST
Created attachment 111022 [details]
X Configuration
Comment 7 Luis Marqueta 2005-02-12 02:55:30 EST
Created attachment 111023 [details]
last X log file
Comment 8 Luis Marqueta 2005-02-12 02:58:30 EST
Created attachment 111024 [details]
/var/log/messages
Comment 11 Mike A. Harris 2005-03-07 14:25:15 EST
We've fixed a problem similar to this in RHEL4U1.  This issue
is probably a duplicate of the fixed issue.  Please test xorg-x11
6.8.2 to determine if it resolves the issue.  You can obtain
test rpms from the following URL:

    http://people.redhat.com/mharris/testing/4E

Please download these rpms as soon as you can, as they may be
removed in a few days.

Setting status to "MODIFIED".  If the problem persists, change
status back to "ASSIGNED" and provide additional details, etc.

Note You need to log in before you can comment on or make changes to this bug.