Bug 1476712 - default logging/metrics image tag should be set to v3.6 but not 3.6.0
default logging/metrics image tag should be set to v3.6 but not 3.6.0
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 05:23 EDT by Johnny Liu
Modified: 2017-08-16 15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Scott Dodson 2017-07-31 11:30:15 EDT
All of the images do have the 3.6.0 tag on them now, maybe they didn't before? and Sam has confirmed that this will be the case when they go live so I think this is how it should be.

Can you verify the reason for the curator pod crashlooping?
Comment 2 Johnny Liu 2017-07-31 22:54:15 EDT
(In reply to Scott Dodson from comment #1)
> All of the images do have the 3.6.0 tag on them now, maybe they didn't
> before? and Sam has confirmed that this will be the case when they go live
> so I think this is how it should be.
> 
> Can you verify the reason for the curator pod crashlooping?

Unfortunately, the env was terminated. After searching, found https://bugzilla.redhat.com/show_bug.cgi?id=1445568 should be the same case like here. Just because the 3.6.0 image on ops registry is out-of-date, not the latest one.

Here in this bug I am requesting installer change default image tag to v3.6, so that make sure always latest image is being pulled whatever using which registry.
Comment 3 Johnny Liu 2017-07-31 23:12:51 EDT
Of course, if we could make sure the images which will go live are tagged with 3.6.0 and up-to-date, it is okay to fix this bug after 3.6 GA.
Comment 4 Scott Dodson 2017-08-01 09:33:32 EDT
https://github.com/openshift/openshift-ansible/pull/4958 for master branch, testing real quick
Comment 5 Scott Dodson 2017-08-01 13:49:45 EDT
https://github.com/openshift/openshift-ansible/pull/4966 for release-3.6 branch
Comment 9 errata-xmlrpc 2017-08-10 01:32:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.