Bug 1476741 - [abrt] clinfo: operator delete(): clinfo killed by signal 6
[abrt] clinfo: operator delete(): clinfo killed by signal 6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
28
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom Stellard
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:9d847743897e1c6f0180462b96b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 06:21 EDT by Paul DeStefano
Modified: 2018-04-05 10:38 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-05 10:38:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (90.02 KB, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details
File: cgroup (292 bytes, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details
File: core_backtrace (33.61 KB, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details
File: cpuinfo (1.39 KB, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details
File: dso_list (5.51 KB, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details
File: environ (4.08 KB, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details
File: limits (1.29 KB, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details
File: maps (27.96 KB, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details
File: open_fds (415 bytes, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details
File: proc_pid_status (1.29 KB, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details
File: var_log_messages (302 bytes, text/plain)
2017-07-31 06:21 EDT, Paul DeStefano
no flags Details

  None (edit)
Description Paul DeStefano 2017-07-31 06:21:35 EDT
Description of problem:
Just ran clinfo.  

Version-Release number of selected component:
clinfo-2.2.17.06.14-1.fc26

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        clinfo
crash_function: operator delete
executable:     /usr/bin/clinfo
journald_cursor: s=61b870d8c6864ac1a90e6a00b3904e1a;i=ef696;b=1f8cff23d9d3481dab03a4ff8b2feee3;m=691bbf8b71;t=55599fd7d7d1e;x=d9cb6d4709e1b4ff
kernel:         4.11.11-300.fc26.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            13013
Comment 1 Paul DeStefano 2017-07-31 06:21:41 EDT
Created attachment 1306988 [details]
File: backtrace
Comment 2 Paul DeStefano 2017-07-31 06:21:42 EDT
Created attachment 1306989 [details]
File: cgroup
Comment 3 Paul DeStefano 2017-07-31 06:21:43 EDT
Created attachment 1306990 [details]
File: core_backtrace
Comment 4 Paul DeStefano 2017-07-31 06:21:44 EDT
Created attachment 1306991 [details]
File: cpuinfo
Comment 5 Paul DeStefano 2017-07-31 06:21:46 EDT
Created attachment 1306992 [details]
File: dso_list
Comment 6 Paul DeStefano 2017-07-31 06:21:47 EDT
Created attachment 1306993 [details]
File: environ
Comment 7 Paul DeStefano 2017-07-31 06:21:48 EDT
Created attachment 1306994 [details]
File: limits
Comment 8 Paul DeStefano 2017-07-31 06:21:49 EDT
Created attachment 1306995 [details]
File: maps
Comment 9 Paul DeStefano 2017-07-31 06:21:50 EDT
Created attachment 1306996 [details]
File: open_fds
Comment 10 Paul DeStefano 2017-07-31 06:21:51 EDT
Created attachment 1306997 [details]
File: proc_pid_status
Comment 11 Paul DeStefano 2017-07-31 06:21:52 EDT
Created attachment 1306999 [details]
File: var_log_messages
Comment 12 Igor Gnatenko 2017-07-31 06:55:27 EDT
seems like bug in LLVM
Comment 13 Paul DeStefano 2017-07-31 14:19:28 EDT
Yes!  Oh, please please help fix this.  BOINC has been broken for over a year, now, and, even after kernel, mesa, and LLVM, and hardware upgrades, I still get LLVM errors.
Comment 14 Tom Stellard 2017-08-25 17:50:52 EDT
I've found that uninstalling beignet fixed the crash for me.  But also when I re-installed beignet, the crash did not happen either.
Comment 15 Paul DeStefano 2017-08-25 18:23:12 EDT
Hmm, that's very interesting.  I removed beinget and clinfo doesn't crash for me either, now.

But, how did this help clinfo?

I hope we can still leave this open for LLVM, though, since I have other LLVM problems.  I would double check BOINC soon.
Comment 16 Tom Stellard 2017-08-25 18:30:17 EDT
(In reply to Paul DeStefano from comment #15)
> Hmm, that's very interesting.  I removed beinget and clinfo doesn't crash
> for me either, now.
> 
> But, how did this help clinfo?
> 

My guess is that since beignet statically links llvm/clang and was exporting some clang/llvm symbols that pocl ended up using.  This would be another problem that symbol versioning for LLVM might fix.

> I hope we can still leave this open for LLVM, though, since I have other
> LLVM problems.  I would double check BOINC soon.

If you have other LLVM problems, you should file new bugs for them.
Comment 17 Tom Stellard 2018-03-23 09:39:06 EDT
This is fixed on rawhide by pocl-1.1-1.fc29.x86_64.rpm.
Comment 18 Tom Stellard 2018-03-23 09:43:28 EDT
I think this was fixed by enabling symbol versioning on libLLVM.so.  This is too big of a change to backport to f26,f27, so this fix will first appear in f28.
Comment 19 Fedora Update System 2018-04-02 10:21:49 EDT
pocl-1.1-2.fc28 lldb-6.0.0-3.fc28 clang-6.0.0-5.fc28 llvm-6.0.0-11.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-02c4091319
Comment 20 Fedora Update System 2018-04-03 11:57:24 EDT
clang-6.0.0-5.fc28, lldb-6.0.0-3.fc28, llvm-6.0.0-11.fc28, mesa-18.0.0-2.fc28.1, pocl-1.1-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-02c4091319
Comment 21 Fedora Update System 2018-04-03 19:25:39 EDT
clang-6.0.0-5.fc28 lldb-6.0.0-3.fc28 llvm-6.0.0-11.fc28 mesa-18.0.0-3.fc28 pocl-1.1-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-02c4091319
Comment 22 Fedora Update System 2018-04-04 14:35:19 EDT
clang-6.0.0-5.fc28, lldb-6.0.0-3.fc28, llvm-6.0.0-11.fc28, mesa-18.0.0-3.fc28, pocl-1.1-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-02c4091319
Comment 23 Fedora Update System 2018-04-05 07:48:00 EDT
clang-6.0.0-5.fc28, lldb-6.0.0-3.fc28, llvm-6.0.0-11.fc28, mesa-18.0.0-3.fc28, pocl-1.1-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.