Bug 1476792 - fix issues with /var/run/pulse
fix issues with /var/run/pulse
Status: CLOSED DUPLICATE of bug 1442975
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 09:22 EDT by dac.override
Modified: 2017-07-31 09:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 09:49:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dac.override 2017-07-31 09:22:21 EDT
Description of problem:

issue #1. pulseaudio package installs the "pulse" directory to /var/run. Please install the "pulse" directory to /run instead.

/var/run is legacy since about 5 years.

issue #2. what good does installing /run/pulse do without installing a /usr/lib/tmpfiles.d/pulseaudio.conf that creates /run/pulse?

either dont install /run/pulse or also install a /usr/lib/tmpfiles.d/pulseaudio.conf that creates "/run/pulse"
Comment 1 Rex Dieter 2017-07-31 09:49:13 EDT
actually, I think the package should do both, 1. own the .../run dir, 2. provide a tmpfiles.d snippet, see also related bug #1442975

*** This bug has been marked as a duplicate of bug 1442975 ***

Note You need to log in before you can comment on or make changes to this bug.