Bug 1476831 - fontconfig scriptlet errors on i686 causing compose hangs
fontconfig scriptlet errors on i686 causing compose hangs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 10:47 EDT by Kevin Fenzi
Modified: 2017-07-31 15:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 15:52:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2017-07-31 10:47:25 EDT
i686 images have been hanging in rawhide composes with: 

https://koji.fedoraproject.org/koji/taskinfo?taskID=20921485

https://kojipkgs.fedoraproject.org//work/tasks/1485/20921485/mock_output.log

...
2017-07-31 13:34:08,444: Installing crypto-policies.noarch (375/1317)
2017-07-31 13:34:08,444: Installing fontconfig.i686 (376/1317)
2017-07-31 13:34:08,444: 
2017-07-31 13:34:08,444: The installation was stopped due to incomplete spokes detected while running in non-interactive cmdline mode. Since there cannot be any questions in cmdline mode, edit your kickstart file and retry installation.
2017-07-31 13:34:08,445: The exact error message is:
2017-07-31 13:34:08,445: 
2017-07-31 13:34:08,445: Non interactive installation failed: DNF error: Non-fatal POSTIN scriptlet failure in rpm package fontconfig.
2017-07-31 13:34:08,445: 
2017-07-31 13:34:08,445: The installer will now terminate.
2017-07-31 13:35:42,251: Failed to preset unit, unit sshd.socket does not exist.
2017-07-31 13:37:37,876: Running in chroot, ignoring request.
2017-07-31 14:38:54,520: Non-fatal POSTIN scriptlet failure in rpm package fontconfig
2017-07-31 14:38:54,520: Non-fatal <unknown> scriptlet failure in rpm package fontconfig
2017-07-31 14:38:54,941: Running anaconda failed: process '['anaconda', '--kickstart', '/tmp/koji-image-f27-build-20921485.ks', '--cmdline', '--dirinstall', '--remotelog', '127.0.0.1:35401']' exited with status 1

note that x86_64 has been working fine, only i686 is doing this. 

Perhaps a post script needs a || : at the end to make sure it always exits 0?
Comment 1 Akira TAGOH 2017-07-31 15:52:41 EDT
Ah, indeed. the wrapper script exits with 1 when no executable fc-cache-64 is available.
fixed in 2.12.4-4.fc27

Note You need to log in before you can comment on or make changes to this bug.