Bug 1476843 - User cannot edit own taxonomies
Summary: User cannot edit own taxonomies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.2.10
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-31 15:06 UTC by Tomer Brisker
Modified: 2019-08-12 16:35 UTC (History)
12 users (show)

Fixed In Version: foreman-1.11.0.89-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-21 20:16:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1672 None None None 2018-05-21 20:17:45 UTC

Description Tomer Brisker 2017-07-31 15:06:19 UTC
Description of problem:
A user, even admin, can not edit their own taxonomies.

Version-Release number of selected component (if applicable):
6.2.10

How reproducible:
always

Steps to Reproduce:
1. Create a new user with no taxonomies assigned.
2. Login as the new user and edit own account.
3. Add a location or organization
4. Save user
5. Edit own account again - note the organization/location was not saved

Actual results:
Organization/Location change is not saved

Expected results:
Organization/Location change is saved

Additional info:
This seems to work in upstream develop correctly.

Comment 3 Tomer Brisker 2017-08-01 07:59:28 UTC
Even simpler reproducer:

1. Log in as admin
2. Try to edit own taxonomies (add/remove a location/organization on your account)
3. Save

You will see the save succeed, but going into editing account again you will see the change was not preserved.

Comment 12 Djebran Lezzoum 2017-09-05 12:14:44 UTC
Hi Bryan,

This scenario is not automated, opened an issue for that https://github.com/SatelliteQE/robottelo/issues/5228

Comment 16 jcallaha 2018-04-30 19:49:50 UTC
Verified in Satellite 6.2.15 Snap 2.

Created a new organization and location.
Edited the main admin account to align them.
Saved the config.
Reloaded the edit user page for the admin account.
The orgs and locations were aligned correctly.

Created a new account with admin privileges and no orgs or locations aligned.
Signed in to the new account, being presented with the edit user page.
Aligned the new org and default location to the user.
After logging back in to the test user, the new org and default location were aligned correctly.

Comment 19 errata-xmlrpc 2018-05-21 20:16:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1672


Note You need to log in before you can comment on or make changes to this bug.