Bug 1476854 - openstack-heat-templates: wrong path in deprecation note
openstack-heat-templates: wrong path in deprecation note
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
medium Severity medium
: beta
: 12.0 (Pike)
Assigned To: leseb
Yogev Rabl
Derek
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 11:28 EDT by Alexander Chuzhoy
Modified: 2017-12-13 16:45 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-7.0.0-0.20170821194253.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:45:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 490038 None None None 2017-08-02 10:22 EDT

  None (edit)
Description Alexander Chuzhoy 2017-07-31 11:28:54 EDT
openstack-heat-templates: wrong path in deprecation note

Environment:
openstack-tripleo-heat-templates-7.0.0-0.20170721174554.el7ost.noarch

The issue:

[root@undercloud-0 ~]# head -n4 /usr/share/openstack-tripleo-heat-templates/environments/puppet-ceph-external.yaml 
# ******************************************************************************
# DEPRECATED: Use tripleo-heat-templates/environments/storage/ceph-external.yaml
# instead.
# ******************************************************************************



The file to use instead doesn't exist (instead of ceph-external.yaml we have external-ceph.yaml):
[root@undercloud-0 ~]# ls /usr/share/openstack-tripleo-heat-templates/environments/storage|grep ceph
enable-ceph.yaml
external-ceph.yaml
Comment 3 Yogev Rabl 2017-11-08 11:25:44 EST
Verified on openstack-tripleo-heat-templates-7.0.3-0.20171024200823.el7ost.noarch
Comment 6 errata-xmlrpc 2017-12-13 16:45:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.