Bug 147687 - Installer ignores the scsihosts= boot prompt
Summary: Installer ignores the scsihosts= boot prompt
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-10 16:22 UTC by Ron Reed
Modified: 2007-11-30 22:07 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-03-03 21:39:10 UTC


Attachments (Terms of Use)

Description Ron Reed 2005-02-10 16:22:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
I have some PowerEdge 2550 servers. These servers have both the internal
PERC 3Di raid and a PERC 3Dc card in them.

I am working on creating a Kickstart CD and I have a problem with the
order of how the raid devices are installed. The PERC 3Dc (megaraid) is
found first and gets set-up as /dev/sda, the PERC 3Di (aacraid) get
detected second and gets set-up as /dev/sdb. I need to get the 3Di to be
/dev/sda during the install. I have tried the
scsihosts=aacraid:megaraid:aic7xxx on the boot prompt, but it doesn't
seem to work.


Version-Release number of selected component (if applicable):
anaconda-9.1.4.1-1.RHEL

How reproducible:
Always

Steps to Reproduce:
1. Boot the bootdisk.img from a standard RHE3.0-WS CD
2. At the boot: prompt type vmlinuz scsihosts=aacraid:megaraid:aic7xxx initrd=initrd.img

  

Actual Results:  The install will start, but the megaraid device is setup as /dev/sda and the aacraid device is setup as /dev/sdb

Expected Results:  The scsihosts parameter should have set the aacraid device as scsihost0 and allowed the kernel to set it up as /dev/sda.

Additional info:

Comment 1 Jeremy Katz 2005-02-13 02:39:27 UTC
The scsihosts kernel parameter is only relevant when drivers are compiled into
the kernel and has no meaning if you're using modules (which we do).

Comment 2 Ron Reed 2005-02-13 04:12:19 UTC
Then how are you supposed to control what device gets assigned to what during an
unattended install? The device parameter in the kickstart file does not work either.

Comment 3 Jeremy Katz 2005-02-13 16:44:27 UTC
'linux noprobe' + the device parameter will let you get related results to what
you're looking for.

Comment 4 Ron Reed 2005-02-14 19:54:58 UTC
I have tried the 'noprobe' option with a kickstart file that looks like this:

#syslinux.cfg (partial)
label nfs-dell
  kernel vmlinuz
  append ks=cdrom:/nfs-dell-ks.cfg initrd=initrd.img noprobe


#kickstart file (partial)
install
cdrom
lang en_US.UTF-8
langsupport --default en_US.UTF-8 en_US.UTF-8
device scsi aacraid
device scsi megaraid
device scsi aic7xxx
device eth eepro100
device eth bcm5700
keyboard us
mouse genericwheelps/2 --device psaux
skipx
network --device eth0 --bootproto dhcp --hostname nfs-basic

The kickstart install does not find any drives with this setup. Should I open a
different bug for this problem, since scsihosts was not the problem?


Note You need to log in before you can comment on or make changes to this bug.