Bug 147687 - Installer ignores the scsihosts= boot prompt
Installer ignores the scsihosts= boot prompt
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-02-10 11:22 EST by Ron Reed
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-03-03 16:39:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ron Reed 2005-02-10 11:22:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
I have some PowerEdge 2550 servers. These servers have both the internal
PERC 3Di raid and a PERC 3Dc card in them.

I am working on creating a Kickstart CD and I have a problem with the
order of how the raid devices are installed. The PERC 3Dc (megaraid) is
found first and gets set-up as /dev/sda, the PERC 3Di (aacraid) get
detected second and gets set-up as /dev/sdb. I need to get the 3Di to be
/dev/sda during the install. I have tried the
scsihosts=aacraid:megaraid:aic7xxx on the boot prompt, but it doesn't
seem to work.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot the bootdisk.img from a standard RHE3.0-WS CD
2. At the boot: prompt type vmlinuz scsihosts=aacraid:megaraid:aic7xxx initrd=initrd.img


Actual Results:  The install will start, but the megaraid device is setup as /dev/sda and the aacraid device is setup as /dev/sdb

Expected Results:  The scsihosts parameter should have set the aacraid device as scsihost0 and allowed the kernel to set it up as /dev/sda.

Additional info:
Comment 1 Jeremy Katz 2005-02-12 21:39:27 EST
The scsihosts kernel parameter is only relevant when drivers are compiled into
the kernel and has no meaning if you're using modules (which we do).
Comment 2 Ron Reed 2005-02-12 23:12:19 EST
Then how are you supposed to control what device gets assigned to what during an
unattended install? The device parameter in the kickstart file does not work either.
Comment 3 Jeremy Katz 2005-02-13 11:44:27 EST
'linux noprobe' + the device parameter will let you get related results to what
you're looking for.
Comment 4 Ron Reed 2005-02-14 14:54:58 EST
I have tried the 'noprobe' option with a kickstart file that looks like this:

#syslinux.cfg (partial)
label nfs-dell
  kernel vmlinuz
  append ks=cdrom:/nfs-dell-ks.cfg initrd=initrd.img noprobe

#kickstart file (partial)
lang en_US.UTF-8
langsupport --default en_US.UTF-8 en_US.UTF-8
device scsi aacraid
device scsi megaraid
device scsi aic7xxx
device eth eepro100
device eth bcm5700
keyboard us
mouse genericwheelps/2 --device psaux
network --device eth0 --bootproto dhcp --hostname nfs-basic

The kickstart install does not find any drives with this setup. Should I open a
different bug for this problem, since scsihosts was not the problem?

Note You need to log in before you can comment on or make changes to this bug.