Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1476878 - Rebase virt-what in RHEL 7.5
Rebase virt-what in RHEL 7.5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-what (Show other bugs)
7.5
All Linux
unspecified Severity high
: rc
: 7.5
Assigned To: Richard W.M. Jones
Virtualization Bugs
Jiri Herrmann
: Rebase
Depends On:
Blocks: 1399177 1476742 1455676 1457960 1469590 1562216
  Show dependency treegraph
 
Reported: 2017-07-31 13:12 EDT by Richard W.M. Jones
Modified: 2018-04-10 12:24 EDT (History)
9 users (show)

See Also:
Fixed In Version: virt-what-1.18-3.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_virt-what_ rebased to version 1.18 The _virt-what_ packages have been updated to upstream version 1.18, which provides a number of bug fixes and enhancements over the previous version. Notably, the *virt-what* utility can now detect the following guest virtual machine types: * Guests running on an 64-bit ARM host and booted using the Advanced Configuration and Power Interfaces. * Guests running on the oVirt or Red Hat Virtualization hypervisor. * Guests running on an IBM POWER7 host that uses logical partitioning (LPAR). * Guests running on the FreeBSD bhyve hypervisor. * Guests running on an IBM z Systems host that uses the KVM hypervisor. * Guests emulated using the QEMU Tiny Code Generator (TCG). * Guests running on the OpenBSD virtual machine monitor (VMM) service. * Guests running on the Amazon Web Services (AWS) platform. * Guests running on the Oracle VM Server for SPARC platform. In addition, the following bugs have been fixed: * The *virt-what* utility no longer fails on platforms that do not use the System Managemement BIOS (SMBIOS). * *virt-what* now works correctly even if the $PATH variable is not set.
Story Points: ---
Clone Of:
: 1562216 (view as bug list)
Environment:
Last Closed: 2018-04-10 12:22:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 157800 None None None 2017-08-17 09:33 EDT
Red Hat Product Errata RHBA-2018:0896 None None None 2018-04-10 12:24 EDT

  None (edit)
Description Richard W.M. Jones 2017-07-31 13:12:08 EDT
Description of problem:

virt-what 1.18 was released today:

https://www.redhat.com/archives/virt-tools-list/2017-July/msg00172.html

Currently RHEL 7.4 carries a downstream version of virt-what which
basically consists of all the upstream commits (before 2017/02)
without any version number changes:

http://git.annexia.org/?p=virt-what.git;a=shortlog;h=refs/heads/rhel-7.4

In other words: It's a rebase in all but name.

It may be better to actually rebase virt-what instead, and since
virt-what 1.18 will be in Fedora for 3 or 4 months before RHEL 7.5
comes out it should get plenty of testing.

virt-what has an upstream stable ABI policy so there should be
no regressions by doing this.

Version-Release number of selected component (if applicable):

Current: virt-what-1.13-10.el7
Intended: virt-what 1.18
Comment 3 Thomas Huth 2017-08-17 04:48:27 EDT
FWIW, just a note related to s390x:
To support KVM on s390x in virt-what, we need http://git.annexia.org/?p=virt-what.git;a=commitdiff;h=89c3d9e094934405266688d2061fe1105863ca17 ... so this should be fixed by the rebase to version 1.18, too. (In the unlikely case that the rebase does not happen, we should remember to backport that patch instead)
Comment 7 Jaroslav Suchanek 2017-12-11 08:22:03 EST
Rich, can you please provide text for release notes? Thanks.
Comment 12 errata-xmlrpc 2018-04-10 12:22:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0896

Note You need to log in before you can comment on or make changes to this bug.