Bug 147689 - clearpart setting overwritten in Satellite kickstart module
clearpart setting overwritten in Satellite kickstart module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
medium Severity high
: ---
: ---
Assigned To: Shannon Hughes
Max Spevack
:
Depends On:
Blocks: 145824
  Show dependency treegraph
 
Reported: 2005-02-10 11:39 EST by Wayne Pascoe
Modified: 2007-07-31 15:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 12:06:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Pascoe 2005-02-10 11:39:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
If clearpart is disabled in kickstart (which has to be done in two steps), and other options are then changed, the clearpart setting is restored and set to clear all partitions on all drives. This unexpected behaviour can have very bad consequences.

To disable clearpart, I have to

- Create kickstart 
- Set options, removing --all from clearpart line and update kickstart

At this point, if I view the kickstart, I still see a clearpart line
there, but with no options. I now edit advanced options to remove this
by deselecting the checkbox next to clearpart and clicking the Update
Kickstart button.

Viewing the kickstart now shows no mention of clearpart. This is as
expected and as required.

However, if I now try to edit any of the options, I see that --all is
back in the clearpart box. If I change any options on this page such
as the root password or timezone, clearpart --all is back in the
kickstart. To stop this, every time I make an edit to the options I
have to remove --all from the clearpart box, then go into advanced
options and deselect clearpart.

Turning clearpart on with a default of --all seems to be the default
behaviour every time I edit the options for a kickstart, regardless of
whether or not it is being used in my kickstart. This is incredibly
dangerous, as if this default is enabled.

If instead of --all in the options box, we have a --drives xxx line,
then our preference is not overwritten. However, due to bug 141644 we are not able to specify drives.

Version-Release number of selected component (if applicable):
3.6.0

How reproducible:
Always

Steps to Reproduce:
1. Create kickstart in Satellite
2. Set options, removing --all from clearpart line and update kickstart
3. Edit advanced options, deselect clearpart and update kickstart

At this point, the kickstart is as expected

4. Edit kickstart, select options
5. Change any option (not related to clearpart, e.g. root password)
6. Update kickstart
    

Actual Results:  The kickstart contains 
clearpart --all


Expected Results:  Kickstart should not contain any reference to 
clearpart

Additional info:

If you specify --drives xxx instead of --all as an argument, this is not overwritten. Only an absence of clearpart is overwritten.

Because of bug 141644, I am unable to specify specific drives to the clearpart argument.

It is reasonable to assume that data on some drives may need to be retained during a server reload, such as database partitions, home directories, etc.

This unexpected behaviour can cause significate data loss.
Comment 1 Shannon Hughes 2005-02-15 13:48:06 EST
fixed in rhn 370
Comment 3 Max Spevack 2005-03-13 12:52:26 EST
This is working well now.  Tested both cases on satellite, and the
second case (since it's more interesting) on hosted.
Comment 4 Todd Warner 2005-04-08 12:06:02 EDT
mass move: PROD_READY --> CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.