Bug 1476904 - [RFE] [TechPreview] Director Ansible Integration - config-download
Summary: [RFE] [TechPreview] Director Ansible Integration - config-download
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: James Slagle
QA Contact: Gurenko Alex
URL:
Whiteboard:
: 1645615 (view as bug list)
Depends On:
Blocks: 1500844 1558145
TreeView+ depends on / blocked
 
Reported: 2017-07-31 18:39 UTC by James Slagle
Modified: 2018-11-13 17:01 UTC (History)
14 users (show)

Fixed In Version: python-tripleoclient-9.0.1-0.20180119233147.el7ost openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost openstack-tripleo-common-8.3.1-0.20180123050219.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:33:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:34:57 UTC

Description James Slagle 2017-07-31 18:39:35 UTC
RFE to capture future use cases around Director and Ansible integration that we may be able to accomplish in the OSP 13 timeframe.

Comment 5 Emilien Macchi 2017-10-11 23:04:36 UTC
please ack rhos-13.0

Comment 9 James Slagle 2017-12-07 18:02:55 UTC
the RFE is completed and ON_DEV. The upstream docs detailing how it works are:

https://docs.openstack.org/tripleo-docs/latest/install/advanced_deployment/ansible_config_download.html

We are not going to make this the default in 13, but plan to do so in 14 as captured in this RFE:

https://bugzilla.redhat.com/show_bug.cgi?id=1523328

Comment 10 James Slagle 2017-12-12 14:02:59 UTC
moving to POST all the feature enablement patches have merged upstream

Comment 12 Jaromir Coufal 2018-01-24 14:28:51 UTC
As agreed we are targeting this feature to be in tech-preview for OSP13 (not a default) and fully supported default in the following version. Changing this tracker to tech-preview.

Comment 18 Omri Hochman 2018-06-06 15:05:23 UTC
verified that the tech-preview code was merged in osp13 - this feature is TECH-PREVIEW and not fully supported.  I would re-command to use at your own risk, as there are still issues that will be fixed during OSP14.

Comment 20 errata-xmlrpc 2018-06-27 13:33:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086

Comment 21 Artem Hrechanychenko 2018-11-13 17:01:46 UTC
*** Bug 1645615 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.