Bug 1476933 - http: panic serving @: reflect: call of reflect.Value.Int on zero Value
http: panic serving @: reflect: call of reflect.Value.Int on zero Value
Status: CLOSED DUPLICATE of bug 1474752
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 17:00 EDT by Micah Abbott
Modified: 2017-07-31 18:51 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 18:51:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Micah Abbott 2017-07-31 17:00:41 EDT
Booted up Rawhide Atomic Host (Rawhide.20170731.n.0) and tried to use 'docker info', but got the following error:

error during connect: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.26/info: EOF


Looked into the journal and saw a Go panic:

-- Logs begin at Wed 2017-07-19 18:44:23 UTC, end at Mon 2017-07-31 20:59:22 UTC. --
Jul 31 20:55:18 fedora26ah-dev systemd[1]: Starting Docker Application Container Engine...
Jul 31 20:55:18 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:18Z" level=info msg="SUSE:secrets :: enabled"
Jul 31 20:55:18 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:18.709935124Z" level=info msg="Graph migration to content-addressability took 0.00 seconds"
Jul 31 20:55:18 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:18.713143165Z" level=warning msg="Your kernel does not support cgroup rt period"
Jul 31 20:55:18 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:18.713562941Z" level=warning msg="Your kernel does not support cgroup rt runtime"
Jul 31 20:55:18 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:18.715306628Z" level=info msg="Loading containers: start."
Jul 31 20:55:18 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:18.814358298Z" level=info msg="Firewalld running: false"
Jul 31 20:55:19 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:19.376758999Z" level=info msg="Default bridge (docker0) is assigned with an IP address 172.17.0.0/16. Daemon option --bip can be used t
Jul 31 20:55:19 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:19.516430970Z" level=info msg="Loading containers: done."
Jul 31 20:55:19 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:19.575237672Z" level=warning msg="failed to retrieve docker-runc version: unknown output format: runc version 1.0.0-rc2\nspec: 1.0.0-rc
Jul 31 20:55:19 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:19.591040124Z" level=warning msg="failed to retrieve docker-init version: unknown output format: tini version 0.13.0\n"
Jul 31 20:55:19 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:19.592505972Z" level=info msg="Daemon has completed initialization"
Jul 31 20:55:19 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:19.593077030Z" level=info msg="Docker daemon" commit="27e468e/1.13.1" graphdriver=overlay2 version=1.13.1
Jul 31 20:55:19 fedora26ah-dev systemd[1]: Started Docker Application Container Engine.
Jul 31 20:55:19 fedora26ah-dev dockerd-current[883]: time="2017-07-31T20:55:19.688198163Z" level=info msg="API listen on /var/run/docker.sock"
Jul 31 20:56:42 fedora26ah-dev dockerd-current[883]: http: panic serving @: reflect: call of reflect.Value.Int on zero Value
                                                     goroutine 132 [running]:
                                                     net/http.(*conn).serve.func1(0xc420860aa0)
                                                             /usr/lib/golang/src/net/http/server.go:1693 +0xd0
                                                     panic(0x1719220, 0xc42081b2e0)
                                                             /usr/lib/golang/src/runtime/panic.go:491 +0x283
                                                     reflect.Value.Int(0x0, 0x0, 0x0, 0x198c4be)
                                                             /usr/lib/golang/src/reflect/value.go:908 +0x141
                                                     github.com/docker/docker/api/server/middleware.getFdFromWriter(0x25dcb20, 0xc420130000, 0xc42030b085)
                                                             /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/middleware/audit_linux.go:86 +0x4
                                                     github.com/docker/docker/api/server/middleware.logAction(0x25dcb20, 0xc420130000, 0xc420172000, 0xc4202ef200, 0xc420172000, 0x1694380)
                                                             /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/middleware/audit_linux.go:212 +0x
                                                     github.com/docker/docker/api/server/middleware.AuditMiddleware.WrapHandler.func1(0x25e04a0, 0xc4201c8570, 0x25dcb20, 0xc420130000, 0xc420172000, 0xc4201c8510,
                                                             /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/middleware/audit_linux.go:26 +0x5
                                                     github.com/docker/docker/api/server.(*Server).makeHTTPHandler.func1(0x25dcb20, 0xc420130000, 0xc420172000)
                                                             /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/server.go:146 +0x1e5
                                                     net/http.HandlerFunc.ServeHTTP(0xc420885e60, 0x25dcb20, 0xc420130000, 0xc420172000)
                                                             /usr/lib/golang/src/net/http/server.go:1914 +0x44
                                                     github.com/docker/docker/vendor/github.com/gorilla/mux.(*Router).ServeHTTP(0xc4202e6f00, 0x25dcb20, 0xc420130000, 0xc420172000)
                                                             /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/vendor/github.com/gorilla/mux/mux.go:103 +0x
                                                     github.com/docker/docker/api/server.(*routerSwapper).ServeHTTP(0xc4204d68a0, 0x25dcb20, 0xc420130000, 0xc420172000)
                                                             /builddir/build/BUILD/docker-27e468e0954bba26b1176cee25a03560114fcb82/_build/src/github.com/docker/docker/api/server/router_swapper.go:29 +0x70
                                                     net/http.serverHandler.ServeHTTP(0xc420066d00, 0x25dcb20, 0xc420130000, 0xc420172000)
                                                             /usr/lib/golang/src/net/http/server.go:2610 +0xb4
                                                     net/http.(*conn).serve(0xc420860aa0, 0x25de7a0, 0xc42082ee00)
                                                             /usr/lib/golang/src/net/http/server.go:1797 +0x71d
                                                     created by net/http.(*Server).Serve
                                                             /usr/lib/golang/src/net/http/server.go:2711 +0x288



Version of docker included in the compose:

# rpm -q docker
docker-1.13.1-22.git27e468e.fc27.x86_64
Comment 1 Antonio Murdaca 2017-07-31 18:51:17 EDT

*** This bug has been marked as a duplicate of bug 1474752 ***

Note You need to log in before you can comment on or make changes to this bug.