Bug 1476936 - katello-change-hostname should not delete the CA
katello-change-hostname should not delete the CA
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.2.0
Unspecified Unspecified
medium Severity medium (vote)
: GA
: --
Assigned To: John Mitsch
Peter Ondrejka
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 17:02 EDT by John Mitsch
Modified: 2018-02-21 12:05 EST (History)
4 users (show)

See Also:
Fixed In Version: katello-3.4.5
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-21 12:05:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 20440 None None None 2017-07-31 17:02 EDT

  None (edit)
Description John Mitsch 2017-07-31 17:02:01 EDT
Katello change hostname currently regenerates the CA which requires clients and proxies to re-register. We shouldn't have to do this anymore after some installer changes and can keep the CA
Comment 1 John Mitsch 2017-07-31 17:02:05 EDT
Created from redmine issue http://projects.theforeman.org/issues/20440
Comment 2 John Mitsch 2017-07-31 17:02:08 EDT
Upstream bug assigned to jomitsch@redhat.com
Comment 4 pm-sat@redhat.com 2017-08-09 16:11:07 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20440 has been resolved.
Comment 5 Peter Ondrejka 2017-11-13 11:48:32 EST
Tested on Sat 6.3 snap 24, the tool works ok after changes.

But there is no point in removing the necessity to re-register hosts if we still ask users to do it in the success message. So putting back to assigned to make changes in the user message.
Comment 6 John Mitsch 2017-11-13 12:01:37 EST
Peter,

Did you try to use a host after katello-change-hostname that hadn't been re-registered? I believe this step is still necessary despite not changing the CA.

-John
Comment 7 Peter Ondrejka 2017-11-14 09:57:29 EST
Ok my bad :) Yes, I tried and worked for me but that was because I had external DNS redirecting calls to old hostname to the renamed machine. On the second try I confirm re-register is necessary, so verified it is
Comment 8 Bryan Kearney 2018-02-21 12:05:14 EST
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA.

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:0336

Note You need to log in before you can comment on or make changes to this bug.