Bug 1476939 - DockerIronicApiConfigImage missing in autogenerated rhos12.yaml
DockerIronicApiConfigImage missing in autogenerated rhos12.yaml
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common (Show other bugs)
12.0 (Pike)
x86_64 Linux
high Severity high
: beta
: 12.0 (Pike)
Assigned To: Dan Prince
Dan Yasny
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 17:03 EDT by Dan Yasny
Modified: 2018-02-05 14:10 EST (History)
7 users (show)

See Also:
Fixed In Version: openstack-tripleo-common-7.4.1-0.20170807001945.8c46306.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:45:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 483096 None None None 2017-08-01 03:04 EDT
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-15 20:43:25 EST

  None (edit)
Description Dan Yasny 2017-07-31 17:03:15 EDT
Description of problem:
When deploying RHOS12, rhos12.yaml generated with overcloud container image prepare is missing DockerIronicApiConfigImage which in turn causes overcloud with enabled OC ironic to fail

There is an upstream patch available: https://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=81d4c247f5db6811abd7a262572f70b4d470bb8e


Version-Release number of selected component (if applicable):
openstack-swift-proxy-2.14.1-0.20170721185434.5b10cf5.el7ost.noarch
openstack-heat-api-cfn-9.0.0-0.20170721154436.bdddeee.el7ost.noarch
openstack-ironic-inspector-5.1.1-0.20170720220617.b908a30.el7ost.noarch
openstack-mistral-executor-5.0.0-0.20170720143547.6c98f31.el7ost.noarch
openstack-swift-container-2.14.1-0.20170721185434.5b10cf5.el7ost.noarch
puppet-openstack_extras-11.2.0-0.20170721171851.6a9d2aa.el7ost.noarch
openstack-neutron-openvswitch-11.0.0-0.20170721222602.9cb907c.el7ost.noarch
openstack-tripleo-image-elements-7.0.0-0.20170712081605.35068ac.el7ost.noarch
openstack-tripleo-common-7.3.1-0.20170720003002.f0ef9ac.el7ost.noarch
openstack-mistral-common-5.0.0-0.20170720143547.6c98f31.el7ost.noarch
openstack-selinux-0.8.7-2.el7ost.noarch
openstack-nova-placement-api-16.0.0-0.20170721224719.fe46cfa.el7ost.noarch
puppet-openstacklib-11.2.0-0.20170721172003.a3cef1d.el7ost.noarch
python-openstacksdk-0.9.17-0.20170621195806.7946243.el7ost.noarch
python-openstack-mistral-5.0.0-0.20170720143547.6c98f31.el7ost.noarch
openstack-swift-account-2.14.1-0.20170721185434.5b10cf5.el7ost.noarch
openstack-neutron-common-11.0.0-0.20170721222602.9cb907c.el7ost.noarch
openstack-heat-common-9.0.0-0.20170721154436.bdddeee.el7ost.noarch
openstack-ironic-api-8.0.1-0.20170721190058.e003b07.el7ost.noarch
openstack-mistral-api-5.0.0-0.20170720143547.6c98f31.el7ost.noarch
openstack-nova-api-16.0.0-0.20170721224719.fe46cfa.el7ost.noarch
openstack-nova-conductor-16.0.0-0.20170721224719.fe46cfa.el7ost.noarch
openstack-nova-common-16.0.0-0.20170721224719.fe46cfa.el7ost.noarch
openstack-puppet-modules-10.0.0-0.20170315222135.0333c73.el7.1.noarch
openstack-tripleo-heat-templates-7.0.0-0.20170721174554.el7ost.noarch
openstack-keystone-12.0.0-0.20170719224216.025e844.el7ost.noarch
openstack-nova-compute-16.0.0-0.20170721224719.fe46cfa.el7ost.noarch
openstack-heat-api-9.0.0-0.20170721154436.bdddeee.el7ost.noarch
openstack-ironic-conductor-8.0.1-0.20170721190058.e003b07.el7ost.noarch
openstack-tempest-16.1.1-0.20170721223940.e1e6e78.el7ost.noarch
openstack-mistral-engine-5.0.0-0.20170720143547.6c98f31.el7ost.noarch
openstack-nova-scheduler-16.0.0-0.20170721224719.fe46cfa.el7ost.noarch
openstack-glance-15.0.0-0.20170720002347.0752f7f.el7ost.noarch
openstack-swift-object-2.14.1-0.20170721185434.5b10cf5.el7ost.noarch
openstack-neutron-ml2-11.0.0-0.20170721222602.9cb907c.el7ost.noarch
openstack-tripleo-puppet-elements-7.0.0-0.20170721140651.c389fae.el7ost.noarch
openstack-tripleo-validations-7.1.1-0.20170720215108.e6ebdd3.el7ost.noarch
openstack-zaqar-5.0.0-0.20170721081135.9b966b4.el7ost.noarch
openstack-neutron-11.0.0-0.20170721222602.9cb907c.el7ost.noarch
openstack-heat-engine-9.0.0-0.20170721154436.bdddeee.el7ost.noarch
openstack-ironic-common-8.0.1-0.20170721190058.e003b07.el7ost.noarch
openstack-tripleo-common-containers-7.3.1-0.20170720003002.f0ef9ac.el7ost.noarch
python-openstackclient-3.11.0-0.20170613232431.c69304e.el7ost.noarch
openstack-tripleo-ui-7.1.1-0.20170720050235.3cb948f.el7ost.noarch


How reproducible:
always

Steps to Reproduce:
1. deploy with oc ironic enabled

Actual results:
overcloud fails with Resource CREATE failed: resources.ServiceChain:resources.ControllerServiceChain.Property error:resources[43].properties: Property DockerIronicApiConfigImage not assigned
Comment 1 Dmitry Tantsur 2017-08-01 03:04:01 EDT
Assuming the patch upstream fixes it.
Comment 2 Dan Prince 2017-08-01 10:19:37 EDT
This has been fixed upstream by:

http://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=81d4c247f5db6811abd7a262572f70b4d470bb8e

I assumed the next rebuild will pick this up and fix it.
Comment 4 Dan Yasny 2017-08-22 16:21:01 EDT
verified on 
openstack-tripleo-common-containers-7.4.1-0.20170807001945.8c46306.el7ost.noarch
openstack-tripleo-common-7.4.1-0.20170807001945.8c46306.el7ost.noarch
python-tripleoclient-7.2.1-0.20170807222309.a731597.el7ost.noarch
openstack-tripleo-heat-templates-7.0.0-0.20170805163048.el7ost.noarch
openstack-tripleo-puppet-elements-7.0.0-0.20170803140906.4e7d35d.el7ost.noarch
openstack-tripleo-image-elements-7.0.0-0.20170725091025.f3f06c7.el7ost.noarch
openstack-tripleo-validations-7.2.1-0.20170807182119.1f60b6f.el7ost.noarch
puppet-tripleo-7.2.1-0.20170807233007.4600842.el7ost.noarch
Comment 8 errata-xmlrpc 2017-12-13 16:45:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.