Bug 1476982 - data is added to elasticsearch before index templates are loaded [NEEDINFO]
data is added to elasticsearch before index templates are loaded
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.6.z
Assigned To: Jan Wozniak
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 22:20 EDT by Rich Megginson
Modified: 2017-10-25 09:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-25 09:04:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jcantril: needinfo? (pportant)


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2017-07-31 22:20:01 EDT
Description of problem:
Data is added to elasticsearch before index templates are loaded

e.g.
index project.logging.52a8136b-760c-11e7-881a-024829526408.2017.07.31 has this for the hostname field definition:

"hostname": { "type": "string" }

but sometime later:

index project.logging.52a8136b-760c-11e7-881a-024829526408.2017.08.01

  "hostname": { "index": "not_analyzed" }

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
This will really make it difficult for kibana users, especially with dashboards and visualizations
Comment 4 Jeff Cantrill 2017-09-06 17:02:17 EDT
@jan reassigning to you as I think your readiness probe PR https://github.com/openshift/origin-aggregated-logging/pull/609 will resolve this
Comment 6 Anping Li 2017-09-15 01:57:09 EDT
All hostname are correct in Kibana with v3.6.173.0.33. So move bug to verified.

# docker inspect ad0b699423cf  |grep version
                "version": "v3.6.173.0.33"

# oc rsh logging-es-data-master-o012o0zw-1-bj8gx env |grep VER
RECOVER_EXPECTED_NODES=1
RECOVER_AFTER_TIME=5m
ES_CLOUD_K8S_VER=2.4.4.01
ES_VER=2.4.4
JAVA_VER=1.8.0
OSE_ES_VER=2.4.4.13
RECOVER_AFTER_NODES=1
Comment 8 errata-xmlrpc 2017-10-25 09:04:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3049

Note You need to log in before you can comment on or make changes to this bug.