Bug 1477037 - Inconsistency between flash message when creating vs. deleting
Summary: Inconsistency between flash message when creating vs. deleting
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.9.0
Assignee: Harpreet Kataria
QA Contact: Yadnyawalk Tale
URL:
Whiteboard: ui:flash_msg:automate:explorer
Depends On:
Blocks: 1479993
TreeView+ depends on / blocked
 
Reported: 2017-08-01 06:09 UTC by Yadnyawalk Tale
Modified: 2018-03-06 15:31 UTC (History)
5 users (show)

Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1479993 (view as bug list)
Environment:
Last Closed: 2018-03-06 15:31:01 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1486615 None None None Never
Red Hat Bugzilla 1516895 None None None Never

Internal Links: 1486615 1516895

Description Yadnyawalk Tale 2017-08-01 06:09:43 UTC
Description of problem:
Inconsistency between flash message when creating vs. deleting an automate object.

Version-Release number of selected component (if applicable):
5.8.1.5.20170725160636_e433fc0 

How reproducible:
Always (100%)

Steps to Reproduce:
1. Navigate to Automation -> Automate -> Explorer
2. Add new domain under datastore, put name of domain as a 'Name1' and description as a 'Desc1', Save it
(Notice this message -> Automate Domain "Name1" was added)
3. Now, click on 'Name1' and remove domain
(Different message -> Automate Domain "Desc1": Delete successful )

Actual results:
Showing 'Name1' created but 'Desc1' deleted  

Expected results:
It should show 'Name1' deleted while deleting

Additional info:
Video -> https://goo.gl/7Rr9Rb
BZ -> 1474693

Comment 3 CFME Bot 2017-08-03 07:33:48 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/31791dd087fd940aab92cced84485469b8944ecb

commit 31791dd087fd940aab92cced84485469b8944ecb
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Aug 2 19:14:21 2017 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Aug 2 19:29:55 2017 -0400

    Changed Domain/Namespace add/edit flash messages to be consistent
    
    Changed Domain/Namespace add/edit flash messages to be consistent with delete method.
    Added spec tests to verify flash message when deleting/updating records.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1477037

 app/controllers/miq_ae_class_controller.rb       | 10 ++---
 spec/controllers/miq_ae_class_controller_spec.rb | 53 ++++++++++++++++++++++++
 2 files changed, 58 insertions(+), 5 deletions(-)

Comment 5 CFME Bot 2017-08-14 16:43:22 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/34cd9b517aaa65a103e80ac1cb70ab4bcac33416

commit 34cd9b517aaa65a103e80ac1cb70ab4bcac33416
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Aug 14 12:09:17 2017 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Aug 14 12:12:53 2017 -0400

    Fixes spec test failure on Fine branch.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1477037

 spec/controllers/miq_ae_class_controller_spec.rb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comment 6 Yadnyawalk Tale 2017-10-09 12:30:50 UTC
Created attachment 1336386 [details]
Screenshot from 2017-10-09 17-58-13.png

Hi Harpreet,

The issue is not reproducible anymore.
Verified on: 5.9.0.1.20171004215954_13427ce 

Great Fix!
-Thanks


Note You need to log in before you can comment on or make changes to this bug.