Bug 1477109 - [Backport] Add TrunkPort support for heat templates
[Backport] Add TrunkPort support for heat templates
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
high Severity high
: z6
: 10.0 (Newton)
Assigned To: Thomas Hervé
Ronnie Rasouli
: FutureFeature, Triaged, ZStream
: 1484503 (view as bug list)
Depends On: 1485958
Blocks: 1335593 1396159
  Show dependency treegraph
 
Reported: 2017-08-01 04:45 EDT by Aviv Guetta
Modified: 2017-11-15 08:44 EST (History)
19 users (show)

See Also:
Fixed In Version: openstack-heat-7.0.5-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
This update introduces a new resource, `OS::Neutron::Trunk`, that adds support of neutron trunks in heat templates.
Story Points: ---
Clone Of:
: 1485958 (view as bug list)
Environment:
Last Closed: 2017-11-15 08:44:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 442496 None None None 2017-08-28 10:35 EDT
OpenStack gerrit 451799 None None None 2017-08-28 10:36 EDT

  None (edit)
Description Aviv Guetta 2017-08-01 04:45:04 EDT
Description of problem:
Add TrunkPort support for heat templates feature is merged in OSP 12[1]. 
I have a customer who would like to backport this feature to OSP 10.


[1] https://blueprints.launchpad.net/heat/+spec/support-trunk-port


Version-Release number of selected component (if applicable):
Red Hat OpenStack 10.
Comment 6 Thomas Hervé 2017-08-28 10:30:54 EDT
https://review.openstack.org/#/c/442496/ is the main patch that we need to land, with possibly https://review.openstack.org/#/c/451799/ being the funtional tests. It has low impact and is fairly contained, so it's low risk though it adds some testing burden.
Comment 7 Thomas Hervé 2017-08-28 10:31:44 EDT
It won't be backported upstream as we don't backport such features.
Comment 8 Thomas Hervé 2017-08-28 10:35:06 EDT
I opened https://bugzilla.redhat.com/show_bug.cgi?id=1485958 to track for OSP11.
Comment 9 Thomas Hervé 2017-08-28 10:40:13 EDT
Note that we can ignore the patch to heat-templates at https://review.openstack.org/#/c/475794/ as it's for documentation purposes.
Comment 13 Thomas Hervé 2017-10-12 10:19:03 EDT
*** Bug 1484503 has been marked as a duplicate of this bug. ***
Comment 22 Ronnie Rasouli 2017-11-02 04:07:59 EDT
Modified the template with newton, stack has been created with trunk ports, subnet and networks

openstack port list
+--------------------------------------+--------------------+-------------------+--------------------------------------------------+
| ID                                   | Name               | MAC Address       | Fixed IP Addresses                               |
+--------------------------------------+--------------------+-------------------+--------------------------------------------------+
| 2d33990d-49a3-4072-8fe7-ae51d98da35c |                    | fa:16:3e:2b:06:b1 | ip_address='10.10.0.2', subnet_id='69c9321e-     |
|                                      |                    |                   | b27e-42cc-b082-e9090b7644de'                     |
| 692ed8f7-cda4-4b49-a8f7-c0f23e246bfb |                    | fa:16:3e:aa:e6:6e | ip_address='10.0.0.2', subnet_id='60f14a9e-      |
|                                      |                    |                   | 55f9-4508-8a58-cb394c172eb0'                     |
| 70d90bcf-bbf7-43cf-bdec-3e0a0a2aeaff | trunk_sub_port_two | fa:16:3e:05:47:21 | ip_address='10.20.0.9',                          |
|                                      |                    |                   | subnet_id='59460328-2334-4602-8b4c-4d3d4d210c83' |
| 81d05ff1-3735-42dd-93f9-0febfb469471 |                    | fa:16:3e:be:e5:5f | ip_address='10.0.5.2', subnet_id='34c9c1a0-739c- |
|                                      |                    |                   | 427a-83b0-5e5c5fa57540'                          |
| 87977cf0-0dd9-4042-8df5-100c9e491fca | trunk_parent_port  | fa:16:3e:d5:8c:24 | ip_address='10.0.0.11', subnet_id='60f14a9e-     |
|                                      |                    |                   | 55f9-4508-8a58-cb394c172eb0'                     |
| 8c20ca8e-2463-4576-be04-5ff004e971f4 |                    | fa:16:3e:42:34:0d | ip_address='10.20.0.2',                          |
|                                      |                    |                   | subnet_id='59460328-2334-4602-8b4c-4d3d4d210c83' |
| 9c54849d-c0bd-4dad-8514-15b7b2bc4359 | trunk_sub_port_one | fa:16:3e:44:e6:0e | ip_address='10.10.0.10', subnet_id='69c9321e-    |
|                                      |                    |                   | b27e-42cc-b082-e9090b7644de'                     |
| abc879df-7d68-4de5-af9d-777c9cafeaa1 |                    | fa:16:3e:2c:28:30 | ip_address='10.0.5.1', subnet_id='34c9c1a0-739c- |
|                                      |                    |                   | 427a-83b0-5e5c5fa57540'                          |
+--------------------------------------+--------------------+-------------------+--------------------------------------------------+
[stack@undercloud-0 ~]$ openstack subnet list
+--------------------------------------+-------------------------------------+--------------------------------------+--------------+
| ID                                   | Name                                | Network                              | Subnet       |
+--------------------------------------+-------------------------------------+--------------------------------------+--------------+
| 34c9c1a0-739c-427a-83b0-5e5c5fa57540 | heat-subnet                         | 99f1756b-7f62-417c-b8e2-18ab69dc2954 | 10.0.5.0/24  |
| 59460328-2334-4602-8b4c-4d3d4d210c83 | trunk-trunk_subnet_two-omjyvenfoihg | 6a429afc-1577-4eef-9fda-5bfb77b32640 | 10.20.0.0/16 |
| 60f14a9e-55f9-4508-8a58-cb394c172eb0 | trunk-parent_subnet-xu3kwnxvrzmv    | 2f90633e-7dcc-4300-8b19-da84e795ec29 | 10.0.0.0/16  |
| 69c9321e-b27e-42cc-b082-e9090b7644de | trunk-trunk_subnet_one-sehewpbampxs | 144dd9dd-3ca1-4f24-82fa-3b4d7975453e | 10.10.0.0/16 |
| f6ac54d4-349c-4ec1-851f-42d53ab32db9 | external_subnet                     | 3820d1c4-f8f4-4bd4-a4e6-5b919b9b502c | 10.0.0.0/24  |
+--------------------------------------+-------------------------------------+--------------------------------------+--------------+

 openstack network list
+--------------------------------------+----------------------------------+--------------------------------------+
| ID                                   | Name                             | Subnets                              |
+--------------------------------------+----------------------------------+--------------------------------------+
| 144dd9dd-3ca1-4f24-82fa-3b4d7975453e | trunk-trunk_net_one-q3nnmrk4hpdo | 69c9321e-b27e-42cc-b082-e9090b7644de |
| 2f90633e-7dcc-4300-8b19-da84e795ec29 | trunk-parent_net-dof43drxnfre    | 60f14a9e-55f9-4508-8a58-cb394c172eb0 |
| 3820d1c4-f8f4-4bd4-a4e6-5b919b9b502c | public                           | f6ac54d4-349c-4ec1-851f-42d53ab32db9 |
| 6a429afc-1577-4eef-9fda-5bfb77b32640 | trunk-trunk_net_two-25orwxpg45ds | 59460328-2334-4602-8b4c-4d3d4d210c83 |
| 99f1756b-7f62-417c-b8e2-18ab69dc2954 | heat-net                         | 34c9c1a0-739c-427a-83b0-5e5c5fa57540 |
+--------------------------------------+----------------------------------+--------------------------------------+

The stack successfully deleted as well
Comment 26 errata-xmlrpc 2017-11-15 08:44:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3232

Note You need to log in before you can comment on or make changes to this bug.