Bug 1477177 - [Doc-RFE] Document GA support for iSCSI
[Doc-RFE] Document GA support for iSCSI
Status: VERIFIED
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0
Unspecified Unspecified
high Severity unspecified
: rc
: 3.0
Assigned To: Aron Gunn
Tejas
: FutureFeature
Depends On: 1477276
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 08:15 EDT by Anjana Suparna Sriram
Modified: 2017-11-08 11:34 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anjana Suparna Sriram 2017-08-01 08:15:42 EDT
Additional info: RHCS 3.0 Content Plan:
https://docs.google.com/document/d/1fp1j6iPr9UPHCMWqqS8QG3SXiSQ3n9Y9a1YogivhtzA/edit
Comment 2 Mike Christie 2017-09-10 13:06:34 EDT
The upstream doc are the current instructions:

http://docs.ceph.com/docs/master/rbd/iscsi-overview/


The only difference between upstream and what we want downstream is going to be that in the upstream doc we sometimes reference upstream packages like the the linux kernel v4.14.

Aron, how did you want to do this? Can you copy over the upstream doc to downstream then have me mark up where we should change the versions, or do you want me to mark up the downstream doc with the changes from upstream, or do you have a way to just do a doc diff similar to how we do diffs on code?
Comment 3 Mike Christie 2017-09-10 13:23:41 EDT
Araon,

For a bug we just found we want to add the following warning:

"Gateway configuration changes are only supported from one gateway at a time. Attempting to run changes concurrently through multiple gateways may lead to
configuration instability and inconsistency"
Comment 4 Mike Christie 2017-09-10 13:23:47 EDT
Araon,

For a bug we just found we want to add the following warning:

"Gateway configuration changes are only supported from one gateway at a time. Attempting to run changes concurrently through multiple gateways may lead to
configuration instability and inconsistency"
Comment 5 Mike Christie 2017-09-11 12:01:40 EDT
Hey Aron,

There is a bug in the upstream and downstream docs. I am adding a comment here, so we do not forget to fix.

In the "iSCSI Discovery and Setup:" section for RHEL the discovery command has an extra "-" so it should be changed from:

iscsiadm -m discovery -t -st 192.168.56.101

to

iscsiadm -m discovery -t st 192.168.56.101
Comment 17 Tejas 2017-10-24 02:00:30 EDT
Looks good, moving to verified.
Comment 21 John Harrigan 2017-10-25 10:22:38 EDT
I read through Chapter 8 of this doc
https://doc-stage.usersys.redhat.com/documentation/en-us/red_hat_ceph_storage/3/html-single/block_device_guide/#configuring_the_iscsi_target_using_ansible

Suggested edits:
1) Table 8.1 contains a lot of variables. I'd suggest providing a sample
   snippet of the RBD_DEVICES and CLIENT_CONNECTIONS sections (perhaps the 
   same text that is already in the 'ceph-iscsi-gw.sample' file). Having
   that text together with the table should help the reader.
2) The last sentence in 'Service Management section is currently
   "The Ansible playbook disables the target service during the deployment." 
   Which leaves the reader wondering if additional configuration steps are
   required to activate ceph iscsi. This could be rewritten to be more
   clear. 
3) The WARNING part of 'Service Management' section states
   "When starting the rbd-target-gw Systemd service, it expects to find the 
    rbd pool. A pool named rbd will need to be created, if one does not exist.
    By default, no rbd pool exists." Shouldn't this be earlier in the doc,
    say under 'Requirements' ?
4) Section 8.3.1 there is a typo in Configuring:
    'multiapth' should be 'multipath'
5) For section 8.3.1 I would suggest these labels for the bolded steps
   * Installing the software packages
   * Configuring Multipath IO
   * CHAP setup and iSCSI Discovery/Login
   * Viewing the Multipath IO configuration
6) This warning in section 8.2.2 should be repeated in section 8.3.1
   within the first step of "CHAP setup and iSCSI Discovery/login".
   " WARNING: CHAP must always be configured. Without CHAP, the target will
     reject any login requests."
Comment 22 Heðin 2017-10-25 14:22:30 EDT
1. To my understanding the QA testbed is vSphere 6.5u1, if that's the case, then the pictures in 8.3.4 should be replaced by the web client, because the C# client application is not available in vsphere 6.5.
1.1 The wording of the CHAP configuration also needs to be adapted according to the web client.
2. Windows server 2016 will not accept a CHAP secret of less than 12 bytes (gives eventid 35 in eventvwr.msc => System).
3. The nodes that act as iGW's require the CEPH Tools repository, to get access to the tcmu-runner and ceph-iscsi-config packages, we expected that the rpm's required to install iGW was part of the OSD repository.
Comment 23 Mike Christie 2017-10-25 14:25:21 EDT
(In reply to Heðin from comment #22)
> 1. To my understanding the QA testbed is vSphere 6.5u1, if that's the case,
> then the pictures in 8.3.4 should be replaced by the web client, because the
> C# client application is not available in vsphere 6.5.

That is right. Aron, I will get you new screen shots.
Comment 26 Heðin 2017-10-26 10:40:29 EDT
In order to run the mpio powershell command Set-MPIOSetting -NewPDORemovePeriod 120, 
"install-windowsfeature Multipath-IO" is needed. This should be noted in the documentation.
Comment 27 Jason Dillaman 2017-10-26 11:13:20 EDT
@Heðin: Is that not covered by step 1 - "Install the iSCSI initiator driver and MPIO tools."
Comment 28 Aron Gunn 2017-10-26 12:03:53 EDT
(In reply to Heðin from comment #22)
> 1. To my understanding the QA testbed is vSphere 6.5u1, if that's the case,
> then the pictures in 8.3.4 should be replaced by the web client, because the
> C# client application is not available in vsphere 6.5.
> 1.1 The wording of the CHAP configuration also needs to be adapted according
> to the web client.
> 2. Windows server 2016 will not accept a CHAP secret of less than 12 bytes
> (gives eventid 35 in eventvwr.msc => System).
> 3. The nodes that act as iGW's require the CEPH Tools repository, to get
> access to the tcmu-runner and ceph-iscsi-config packages, we expected that
> the rpm's required to install iGW was part of the OSD repository.

Heðin,

Thanks for the feedback!

Regarding #2, I'll add a note for the CHAP secret.

Regarding #3, the Ceph iSCSI documentation already has the user enable the Ceph Tools repository.

Best Regards,
Aron
Comment 29 Jason Dillaman 2017-11-03 11:05:53 EDT
@Aron: I have proposed a couple tweaks upstream [1] to the Windows Server 2016 initiator setup instructions that should probably be incorporated downstream as well.

[1] https://github.com/ceph/ceph/pull/18704

Note You need to log in before you can comment on or make changes to this bug.