Bug 1477233 - Huge coredumps os atomic-openshift-api.service when it restarts [NEEDINFO]
Huge coredumps os atomic-openshift-api.service when it restarts
Status: CLOSED DUPLICATE of bug 1486416
Product: OpenShift Online
Classification: Red Hat
Component: Master (Show other bugs)
3.x
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Mace
Wang Haoran
: OnlineStarter, OpsBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 10:18 EDT by Gabor Burges
Modified: 2017-09-15 15:36 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-15 15:36:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mstaeble: needinfo? (gburges)


Attachments (Terms of Use)

  None (edit)
Description Gabor Burges 2017-08-01 10:18:15 EDT
Description of problem:

When the api service gets in a bad state (not normally stopped) and restarts it writes a huge core.<#####> file in /var/lib/origin/

This is especially problematic on starter-us-east-1 because the core file takes up more than 11GB of the 16GB of the filesystem

Moving said core file out of the dir kills the process again, generating another huge core file

Version-Release number of selected component (if applicable):
oc v3.6.170
kubernetes v1.6.1+5115d708d7
features: Basic-Auth GSSAPI Kerberos SPNEGO

openshift v3.6.170
kubernetes v1.6.1+5115d708d7


How reproducible:
get the atomic-openshift-api.service in a bad state 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Similar to https://bugzilla.redhat.com/show_bug.cgi?id=1277329
Comment 1 Seth Jennings 2017-08-08 18:38:45 EDT
What is the output of "ulimit -c"?

If "unlimited" try adding the following line to /etc/security/limits.conf:

* hard core 0

Setting coredump file size limits would really need to be addressed at the installer level.
Comment 3 Matthew Staebler 2017-08-16 17:14:18 EDT
Need confirmation from the reporter that setting the coredump file size limits resolves the issue.

See Comment #1.

Note You need to log in before you can comment on or make changes to this bug.