Bug 1477248 - [Doc-RFE] Document async messenger
[Doc-RFE] Document async messenger
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: rc
: 3.0
Assigned To: John Wilkins
shylesh
Bara Ancincova
: Documentation, FutureFeature
Depends On: 1477276
Blocks: 1494421
  Show dependency treegraph
 
Reported: 2017-08-01 10:48 EDT by Anjana Suparna Sriram
Modified: 2017-12-25 22:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
.The `async` messenger The `async` messenger is used by default instead of the `simple` one. For details see the link:https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/3/html-single/configuration_guide/#messaging[Messaging] and link:https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/3/html-single/configuration_guide/#asyncmessenger_settings[Async Messenger Settings] section in the Configuration Guide for Red{nbsp}Hat Ceph Storage 3.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-25 22:39:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anjana Suparna Sriram 2017-08-01 10:48:19 EDT
Additional info: RHCS 3.0 Content Plan:
https://docs.google.com/document/d/1fp1j6iPr9UPHCMWqqS8QG3SXiSQ3n9Y9a1YogivhtzA/edit
Comment 2 John Wilkins 2017-10-20 17:59:07 EDT
According to development, users should not have to make any changes. However, we do support both simple and asynchronous messaging types. Additionally, we support the POSIX transport type. Documentation covers undocumented ms_type, ms_type_public, ms_type_cluster, and ms_async... settings.

See https://gitlab.cee.redhat.com/red-hat-ceph-storage-documentation/doc-Red_Hat_Ceph_Storage_3-Configuration_Guide/commit/2657011dc9794f19a95c5e49aaba00b69da38bcf  for details.
Comment 9 John Wilkins 2017-11-03 12:58:25 EDT
Removed the fine-grained async setting for now due to lack of feedback from engineering on the recent comments. Ceph uses these features whether we like it or not. The setting content is from upstream and contains tuning information.

My conversation with Josh is that people should not have to set ms_type, but we agreed to document it anyway.

Note You need to log in before you can comment on or make changes to this bug.