Bug 1477300 - [RFE] dynamic bucket sharding
[RFE] dynamic bucket sharding
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
3.0
All All
high Severity high
: rc
: 3.0
Assigned To: Orit Wasserman
vidushi
Erin Donnelly
: FutureFeature
Depends On:
Blocks: 1494421
  Show dependency treegraph
 
Reported: 2017-08-01 12:46 EDT by Matt Benjamin (redhat)
Modified: 2017-12-05 18:38 EST (History)
12 users (show)

See Also:
Fixed In Version: RHEL: ceph-12.1.4-1.el7cp Ubuntu: ceph_12.1.4-2redhat1xenial
Doc Type: Enhancement
Doc Text:
.Support for dynamic bucket resharding The Ceph Object Gateway now supports the `rgw_dynamic_resharding` parameter. The process for dynamic bucket resharding periodically checks all the Ceph Object Gateway buckets and detects buckets that require resharding. If a bucket has grown larger than specified by the `rgw_max_objs_per_shard` parameter, the Ceph Object Gateway reshards the bucket dynamically in the background. For details, see the link:https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/3/html-single/object_gateway_guide_for_red_hat_enterprise_linux/#resharding-bucket-index-rhcs3[Dynamic Bucket Index Resharding in RHCS 3] section in the Object Gateway Guide for Red Hat Enterprise Linux. Note that dynamic bucket resharding is disabled in multi-site configuration.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-05 18:38:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github ceph/ceph/pull/15493 None None None 2017-08-03 10:44 EDT

  None (edit)
Description Matt Benjamin (redhat) 2017-08-01 12:46:38 EDT
Provide a mechanism to dynamically re-shard buckets which have exceeded a configurable size threshold.

In this version:

1. object operations on buckets being resharded are blocked until completion
2. bucket shard count can expand but not shrink
Comment 2 Matt Benjamin (redhat) 2017-08-01 17:23:43 EDT
upstream PR: https://github.com/ceph/ceph/pull/11230
Comment 3 Ken Dreyer (Red Hat) 2017-08-02 12:12:42 EDT
Matt, PR 11230 went into Jewel back in https://github.com/ceph/ceph/pull/13341 (v10.2.6), so that has been in the product for a while now.

Is there another PR for this BZ? I'm wondering if http://tracker.ceph.com/issues/17550 does not really cover dynamic resharding?
Comment 4 Orit Wasserman 2017-08-03 04:45:14 EDT
(In reply to Ken Dreyer (Red Hat) from comment #3)
> Matt, PR 11230 went into Jewel back in
> https://github.com/ceph/ceph/pull/13341 (v10.2.6), so that has been in the
> product for a while now.
> 
> Is there another PR for this BZ? I'm wondering if
> http://tracker.ceph.com/issues/17550 does not really cover dynamic
> resharding?

Ken you are correct that was the offline resharding pr.
This is the dynamic resharding pr:
https://github.com/ceph/ceph/pull/15493
Comment 5 Ken Dreyer (Red Hat) 2017-08-16 17:20:13 EDT
On ceph-devel:

On Tue, Aug 8, 2017 at 11:11 AM, Matt Benjamin <mbenjami@redhat.com> wrote:
> I think dynamic resharding bugs are going
> to take longer than 1 day to resolve, so will need to follow the .0.

We need links to these bugs.
Comment 14 errata-xmlrpc 2017-12-05 18:38:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387

Note You need to log in before you can comment on or make changes to this bug.