Bug 1477316 - os-net-config does not pick up an existing mapping file [NEEDINFO]
os-net-config does not pick up an existing mapping file
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-net-config (Show other bugs)
10.0 (Newton)
x86_64 Linux
high Severity high
: z5
: 10.0 (Newton)
Assigned To: RHOS Maint
Shai Revivo
: Triaged, ZStream
Depends On: 1457465
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 14:40 EDT by Bob Fournier
Modified: 2018-02-06 14:58 EST (History)
16 users (show)

See Also:
Fixed In Version: os-net-config-5.2.0-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1457465
Environment:
Last Closed: 2017-09-28 12:35:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
samccann: needinfo? (rhos-maint)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 470073 None None None 2017-08-01 14:40 EDT
OpenStack gerrit 475531 None None None 2017-08-01 14:40 EDT
OpenStack gerrit 489709 None None None 2017-08-31 15:58 EDT

  None (edit)
Comment 1 Bob Fournier 2017-08-01 14:58:40 EDT
Upstream backport to stable/newton - https://review.openstack.org/#/c/489709/
Comment 4 mlammon 2017-09-21 16:57:54 EDT
Worked with Bob Fournier to verify this bug
Installed: /etc/yum.repos.d/rhos-release-10.repo
# rhos-release 10   -p 2017-09-20.2

environment
[root@undercloud ~]# rpm -qa | grep os-net-config-5.2
os-net-config-5.2.0-4.el7ost.noarch

1. checked the patch was there by inspection
2. running os-net-config using —noop with —debug to print out what it would do
3. passed a config.json file that had a bond in it and also mapping file that reversed the normal mapping, so nic1 is mapped to eth1 and nic2 is mapped to eth0

Output 
[2017/06/13 11:56:11 AM] [INFO] nic2 in mapping file mapped to: eth0
Comment 6 errata-xmlrpc 2017-09-28 12:35:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2825

Note You need to log in before you can comment on or make changes to this bug.