Bug 1477324 - Failed to boot Instance: ERROR nova.virt.libvirt.guest - Error launching a defined domain with XML
Failed to boot Instance: ERROR nova.virt.libvirt.guest - Error launching a de...
Status: CLOSED DUPLICATE of bug 1477720
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
12.0 (Pike)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Eoghan Glynn
Joe H. Rahme
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 15:28 EDT by Yuri Obshansky
Modified: 2017-08-02 13:58 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 12:41:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nova-compute.log file (403.97 KB, text/plain)
2017-08-01 15:30 EDT, Yuri Obshansky
no flags Details
cli command to create instance flow (9.40 KB, text/plain)
2017-08-01 15:31 EDT, Yuri Obshansky
no flags Details

  None (edit)
Description Yuri Obshansky 2017-08-01 15:28:22 EDT
Description of problem:
Instance was created with status Error on puddle # rhos-release 12   -p 2017-07-27.1
Found error in /var/log/containers/nova/nova-compute.log
2017-08-01 17:58:43.025 1 ERROR nova.virt.libvirt.guest [req-0ca47ada-eb73-4b6a-9f61-8b20f94d995a 2a60040ee12648d4ab4e8c67daf6d6b7 c4599f7ea4a84d5daaf58a959206cd13 - default default] Error launching a defined domain with XML: <domain type='kvm'>
  <name>instance-0000000e</name>
  <uuid>e46ad9c7-4e9d-4303-ada4-8422804664c4</uuid>
  <metadata>
    <nova:instance xmlns:nova="http://openstack.org/xmlns/libvirt/nova/1.0">
      <nova:package version="16.0.0-0.20170719155122.7ae3753.el7ost"/>
      <nova:name>test-1-vm</nova:name>
      <nova:creationTime>2017-08-01 17:58:39</nova:creationTime>
      <nova:flavor name="m1.medium">
        <nova:memory>4096</nova:memory>
        <nova:disk>40</nova:disk>
        <nova:swap>0</nova:swap>
        <nova:ephemeral>0</nova:ephemeral>
        <nova:vcpus>2</nova:vcpus>
      </nova:flavor>
      <nova:owner>
        <nova:user uuid="2a60040ee12648d4ab4e8c67daf6d6b7">admin</nova:user>
        <nova:project uuid="c4599f7ea4a84d5daaf58a959206cd13">admin</nova:project>
      </nova:owner>
      <nova:root type="image" uuid="c374b02b-22ce-4500-97c7-ca2d16767b90"/>
    </nova:instance>
  </metadata>
  <memory unit='KiB'>4194304</memory>
  <currentMemory unit='KiB'>4194304</currentMemory>
  <vcpu placement='static'>2</vcpu>
  <cputune>
    <shares>2048</shares>
  </cputune>
  <sysinfo type='smbios'>
    <system>
      <entry name='manufacturer'>Red Hat</entry>
      <entry name='product'>OpenStack Compute</entry>
      <entry name='version'>16.0.0-0.20170719155122.7ae3753.el7ost</entry>
      <entry name='serial'>4c4c4544-0052-5910-8057-c6c04f365831</entry>
      <entry name='uuid'>e46ad9c7-4e9d-4303-ada4-8422804664c4</entry>
      <entry name='family'>Virtual Machine</entry>
    </system>
  </sysinfo>
  <os>
    <type arch='x86_64' machine='pc-i440fx-rhel7.4.0'>hvm</type>
    <boot dev='hd'/>
    <smbios mode='sysinfo'/>
  </os>
  <features>
    <acpi/>
    <apic/>
  </features>
  <cpu mode='host-model' check='partial'>
    <model fallback='allow'/>
    <topology sockets='2' cores='1' threads='1'/>
  </cpu>
  <clock offset='utc'>
    <timer name='pit' tickpolicy='delay'/>
    <timer name='rtc' tickpolicy='catchup'/>
    <timer name='hpet' present='no'/>
  </clock>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2' cache='none'/>
      <source file='/var/lib/nova/instances/e46ad9c7-4e9d-4303-ada4-8422804664c4/disk'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </disk>
    <controller type='usb' index='0' model='piix3-uhci'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/>
    </controller>
    <controller type='pci' index='0' model='pci-root'/>
    <interface type='bridge'>
      <mac address='fa:16:3e:df:90:ec'/>
      <source bridge='qbr6d306bea-63'/>
      <target dev='tap6d306bea-63'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>
    <serial type='pty'>
      <log file='/var/lib/nova/instances/e46ad9c7-4e9d-4303-ada4-8422804664c4/console.log' append='off'/>
      <target port='0'/>
    </serial>
    <console type='pty'>
      <log file='/var/lib/nova/instances/e46ad9c7-4e9d-4303-ada4-8422804664c4/console.log' append='off'/>
      <target type='serial' port='0'/>
    </console>
    <input type='tablet' bus='usb'>
      <address type='usb' bus='0' port='1'/>
    </input>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes' listen='172.16.0.11' keymap='en-us'>
      <listen type='address' address='172.16.0.11'/>
    </graphics>
    <video>
      <model type='cirrus' vram='16384' heads='1' primary='yes'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
    <memballoon model='virtio'>
      <stats period='10'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </memballoon>
  </devices>
</domain>
: libvirtError: Cannot recv data: Connection reset by peer

See details in attached log file. 

Version-Release number of selected component (if applicable):
kernel-3.10.0-693.el7.x86_64
libvirt-3.2.0-14.el7.x86_64
puppet-nova-11.2.0-0.20170718023405.a27c62c.el7ost.noarch
openstack-nova-conductor-16.0.0-0.20170719155122.7ae3753.el7ost.noarch
openstack-nova-compute-16.0.0-0.20170719155122.7ae3753.el7ost.noarch
openstack-nova-scheduler-16.0.0-0.20170719155122.7ae3753.el7ost.noarch
openstack-nova-common-16.0.0-0.20170719155122.7ae3753.el7ost.noarch
openstack-nova-placement-api-16.0.0-0.20170719155122.7ae3753.el7ost.noarch
python-novaclient-9.0.1-0.20170621200422.ddb386b.el7ost.noarch
python-nova-16.0.0-0.20170719155122.7ae3753.el7ost.noarch
openstack-nova-novncproxy-16.0.0-0.20170719155122.7ae3753.el7ost.noarch
openstack-nova-api-16.0.0-0.20170719155122.7ae3753.el7ost.noarch
openstack-nova-console-16.0.0-0.20170719155122.7ae3753.el7ost.noarch
openstack-nova-migration-16.0.0-0.20170719155122.7ae3753.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. openstack project create test-1
2. openstack user create test-1 --project test-1
3. openstack network create test-1-net --project test-1
4. neutron subnet-create --name test-1-subnet --allocation-pool=start=172.1.0.5,end=172.1.0.250 --gateway=172.1.0.2 test-1-net 172.1.0.0/24
5. nova boot --image rhel --nic net-id=e8aa35c0-b2e6-44d7-baad-64606e068245 --flavor m1.medium test-1-vm

Actual results:
Created instance has Error status

Expected results:
Successfully create instance



Additional info:
Comment 1 Yuri Obshansky 2017-08-01 15:30 EDT
Created attachment 1307757 [details]
nova-compute.log file
Comment 2 Yuri Obshansky 2017-08-01 15:31 EDT
Created attachment 1307758 [details]
cli command to create instance flow
Comment 3 Yuri Obshansky 2017-08-01 15:44:26 EDT
Forget to specify:
It's the baremetal environment 
1 undercloud + 3 controller + 6 computes nodes
System: Dell Inc. PowerEdge R620/01W23F,
OS: Red Hat Enterprise Linux Server release 7.4 (Maipo)
Comment 4 Yuri Obshansky 2017-08-02 12:41:35 EDT
Hi,
After deep investigation the issue was sorted out.
It related to openstack installation and deploy, and not functionality.
The issue was resolved by running the script from 
http://file.rdu.redhat.com/~achuzhoy/containers/launch-instance-workarounds.sh
and selinux was enabled on OC nodes.
I hope, those director problems have already reported, 
so, not bug.
Yuri
Comment 5 Alexander Chuzhoy 2017-08-02 13:58:00 EDT

*** This bug has been marked as a duplicate of bug 1477720 ***

Note You need to log in before you can comment on or make changes to this bug.