This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1477326 - CFME Install on OCP uses docker.io images
CFME Install on OCP uses docker.io images
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Scott Dodson
Gaoyun Pei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 15:36 EDT by Scott Dodson
Modified: 2017-08-16 15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dodson 2017-08-01 15:36:03 EDT
CFME should deploy on OCP 3.6 using CFME 4.5 images from registry.access.redhat.com not images from docker.io.
Comment 3 Gaoyun Pei 2017-08-02 03:04:53 EDT
Verify this bug with openshift-ansible-3.6.173.0.2-1.git.0.f6cbecf.el7.noarch

Prepare an ocp-3.6 cluster which meet the following requirements:
1. cluster sizing requirements
Type	    Size   CPUs	 Memory
Masters	    1+	   8	 12GB
Nodes	    2+	   4	 8GB
PV Storage  25GB   N/A	 N/A
2. NFS server is on the master host
3. PV backing NFS storage volume is mounted on /exports/


Add openshift_cfme_install_app=true in the ansible inventory file, run the cfme installation entry point playbook
ansible-playbook -i host /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cfme/config.yml

After playbook finished, wait for manageiq pod becomes ready, make sure no error logs in manageiq/memcached/postgresql pods
[root@qe-gpei-bug-master-nfs-1 ~]# oc get pod
NAME                 READY     STATUS    RESTARTS   AGE
manageiq-0           1/1       Running   0          7m
memcached-1-0j89q    1/1       Running   0          7m
postgresql-1-nsm4j   1/1       Running   0          7m

Check the images pulled on the node, all of the 3 images come from registry.access.redhat.com/cloudforms45
[root@qe-gpei-bug-node-registry-router-1 ~]# docker images|grep cfme
registry.access.redhat.com/cloudforms45/cfme-openshift-postgresql   <none>              2343bb300369        6 weeks ago         295.3 MB
registry.access.redhat.com/cloudforms45/cfme-openshift-memcached    <none>              7cedb9197d82        6 weeks ago         242.8 MB
registry.access.redhat.com/cloudforms45/cfme-openshift-app             latest              73fcaf348d64        6 weeks ago         1.849 GB


Check the related processes were running in miq pod
[root@qe-gpei-bug-master-nfs-1 ~]# oc rsh manageiq-0
sh-4.2# ps -ef|grep -i miq
root        347      1  6 02:39 ?        00:16:52 MIQ Server
root       3290    347  0 02:41 ?        00:00:53 MIQ: MiqGenericWorker id: 1, queue: generic
root       3298    347  0 02:41 ?        00:00:34 MIQ: MiqGenericWorker id: 2, queue: generic
root       3306    347  0 02:41 ?        00:00:37 MIQ: MiqPriorityWorker id: 3, queue: generic
root       3311    347  0 02:41 ?        00:00:37 MIQ: MiqPriorityWorker id: 4, queue: generic
root       3322    347  0 02:41 ?        00:01:01 MIQ: MiqScheduleWorker id: 5
root       3338    347  0 02:41 ?        00:00:12 MIQ: MiqEventHandler id: 6, queue: ems
root       3346    347  0 02:41 ?        00:00:14 MIQ: MiqReportingWorker id: 7, queue: reporting
root       3354    347  0 02:41 ?        00:00:15 MIQ: MiqReportingWorker id: 8, queue: reporting
root       3365    347  0 02:41 ?        00:00:23 puma 3.3.0 (tcp://127.0.0.1:5000) [MIQ: Web Server Worker]
root       3373    347  0 02:41 ?        00:00:52 puma 3.3.0 (tcp://127.0.0.1:3000) [MIQ: Web Server Worker]
root       3381    347  0 02:41 ?        00:00:22 puma 3.3.0 (tcp://127.0.0.1:4000) [MIQ: Web Server Worker]

Visit the CFME webconsole
[root@qe-gpei-bug-master-nfs-1 ~]# oc get route
NAME       HOST/PORT                               PATH      SERVICES   PORT      TERMINATION   WILDCARD
manageiq   manageiq-cfme.0802-bv0.qe.rhcloud.com             manageiq   https     passthrough   None
Could login the URL https://manageiq-cfme.0802-bv0.qe.rhcloud.com/ with default credential: admin/smartvm
Comment 5 errata-xmlrpc 2017-08-10 01:32:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.