Bug 1477334 - nodejs-6.10.3-1.el7.x86_64 should require http-parser-2.7.1-3.el7.x86_64
nodejs-6.10.3-1.el7.x86_64 should require http-parser-2.7.1-3.el7.x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: nodejs (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: NodeJS Packaging SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 16:03 EDT by Alexander Todorov
Modified: 2017-08-02 03:14 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 03:14:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2017-08-01 16:03:35 EDT
The changelog from nodejs has this entry at the top:
* Wed May 10 2017 Stephen Gallagher <sgallagh@redhat.com> - 1:6.10.3-1
- Update to 6.10.3 (LTS)
- https://nodejs.org/en/blog/release/v6.10.3/
- Stop using the bundled http-parser now that there is an upstream
  release with a new-enough version.

The problem with this change is that it didn't pull in http-parser as a dependency which broke my webserver until I was able to find the fix of doing the manual package install. Please make sure that the http-parser package get added into the dependency list. 

Note: originally filed at https://bugs.centos.org/view.php?id=13380 by GeneBean but closed b/c that was not the appropriate place.

I've been bitten by this same issue as well. Please fix it.
Comment 1 Zuzana Svetlikova 2017-08-02 03:14:22 EDT
Latest build in stable is 6.11.1, so please use that one.
https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-93f422baa0

Note You need to log in before you can comment on or make changes to this bug.