Red Hat Bugzilla – Bug 1477334
nodejs-6.10.3-1.el7.x86_64 should require http-parser-2.7.1-3.el7.x86_64
Last modified: 2017-08-02 03:14:22 EDT
The changelog from nodejs has this entry at the top:
* Wed May 10 2017 Stephen Gallagher <email@example.com> - 1:6.10.3-1
- Update to 6.10.3 (LTS)
- Stop using the bundled http-parser now that there is an upstream
release with a new-enough version.
The problem with this change is that it didn't pull in http-parser as a dependency which broke my webserver until I was able to find the fix of doing the manual package install. Please make sure that the http-parser package get added into the dependency list.
Note: originally filed at https://bugs.centos.org/view.php?id=13380 by GeneBean but closed b/c that was not the appropriate place.
I've been bitten by this same issue as well. Please fix it.
Latest build in stable is 6.11.1, so please use that one.