Bug 1477344 - After upgrade from Sat 5.6 or 5.7 to 5.8, cdn-sync does not see channels that were synced prior to upgrade
After upgrade from Sat 5.6 or 5.7 to 5.8, cdn-sync does not see channels that...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
580
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jan Dobes
Patrik Segedy
:
Depends On:
Blocks: sat58-errata
  Show dependency treegraph
 
Reported: 2017-08-01 16:40 EDT by Candace Sheremeta
Modified: 2017-10-19 08:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-backend-2.5.3-152-sat
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-19 07:57:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Candace Sheremeta 2017-08-01 16:40:40 EDT
Description of problem:
Many customers have been running into the problem where, after upgrading from Satellite 5.6 or 5.7 to Satellite 5.8, running a full cdn-sync shows there is nothing to do as no channels are synced, and running # cdn-sync -l shows no channels synced (nothing marked with "p").

Version-Release number of selected component (if applicable):
5.8

How reproducible:
?

Steps to Reproduce:
1. Have a Sat 5.6 or 5.7 built with channels synced
2. Upgrade to Satellite 5.8
3. Run cdn-sync or cdn-sync -l

Actual results:
Output shows no channels synced

Expected results:
Channels that were synced prior to upgrade should be listed/synced

Additional info:
Comment 1 Candace Sheremeta 2017-08-01 16:42:14 EDT
Forgot to mention: syncing the channels individually with # cdn-sync -c <channel-label> works and does get the channels to show up when running # cdn-sync -l or a full # cdn-sync
Comment 3 Jan Dobes 2017-08-08 05:32:03 EDT
This is caused by change in spacewalk.git(master):

2f6327ba8b098a74d4d54493d5fb2b0fce947b2b

Basically it sees only channels with some CDN repositories already attached - after upgrade there are none, this needs to be enhanced.
Comment 4 Jan Dobes 2017-08-14 08:11:38 EDT
fixed in spacewalk.git(master):

833fc83cbbf2606d6dbb79fb125488822f3157e8

It now adds all null-org channels and all custom-org channels with associated null-org repositories to synced_channels set. Running cdn-sync without parameters will now try to sync channels which were previously ignored (previously, only channels synced at least once manually were attempted) - however, it's possible this sync will fail for some channels if there is something missing for them (error in channel mapping, entitlement error etc.).
Comment 7 Patrik Segedy 2017-09-13 10:31:39 EDT
Steps to verify:
1. Install Satellite 5.6
2. Sync channels rhel-x86_64-server-7 and rhn-tools-rhel-x86_64-server-7 from dump
3. Upgrade to Satellite 5.8
4. With old package cdn-sync -l shows no channels that were previously imported/synced
spacewalk-backend-2.5.3-151.el6sat.noarch.rpm
# cdn-sync -l | egrep "p\ "
08:40:22 p = previously imported/synced channel

5. Update to spacewalk-backend-2.5.3-152.el6sat.noarch.rpm and now cdn-sync -l works as expected
# cdn-sync -l | egrep "p\ "
08:46:00 p = previously imported/synced channel
08:46:00     p rhel-x86_64-server-7                                        ? packages      (?B)
08:46:00     p rhn-tools-rhel-x86_64-server-7                              ? packages      (?B)

6. Both channels were successfully synced using cdn-sync
# cdn-sync --no-packages --no-errata --no-kickstarts
10:21:45 ======================================
10:21:45 | Channel: rhel-x86_64-server-7
10:21:45 ======================================
10:21:45 Sync of channel started.
10:21:45 Repo URL: https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os
10:21:46 Sync of channel completed in 0:00:01.
10:21:46 ======================================
10:21:46 | Channel: rhn-tools-rhel-x86_64-server-7
10:21:46 ======================================
10:21:46 Sync of channel started.
10:21:46 Repo URL: https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/rhn-tools/os
10:21:47 Sync of channel completed in 0:00:00.
10:21:47 Total time: 0:00:02


VERIFIED
Comment 9 errata-xmlrpc 2017-10-19 07:57:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2915

Note You need to log in before you can comment on or make changes to this bug.