Bug 1477405 - eager-lock should be off for cassandra to work at the moment
eager-lock should be off for cassandra to work at the moment
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
3.12
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On: 1477404
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 22:12 EDT by Pranith Kumar K
Modified: 2017-09-05 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1477404
Environment:
Last Closed: 2017-09-05 13:38:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2017-08-01 22:12:46 EDT
+++ This bug was initially created as a clone of Bug #1477404 +++

Description of problem:
    With the current implementation of eager-lock FINODELK is taking so much
    time that cassandra workload times out and errors out. AFR eager-locking
    needs to be changed similar to EC eager-locking to make things work
    as expected. In the interim, it is better to turn it off
    
    This is how the profile looks if eager-lock is turned on:
          0.35     628.26 us      64.00 us  129882.00 us          42278    FXATTROP
         17.45   16500.54 us     212.00 us  375829.00 us          79568       WRITE
         81.76  209862.12 us      15.00 us 1992486.00 us          29318    FINODELK
    
    This is how profile looks if eager-lock is turned off:
          1.87     283.71 us      65.00 us  298970.00 us          68346    FXATTROP
          6.33     199.04 us      13.00 us  373428.00 us         330524    FINODELK
         10.37    3151.47 us      53.00 us 1528484.00 us          34172       FSYNC
         81.31    5110.45 us     270.00 us 1519722.00 us         165244       WRITE


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-08-01 21:55:06 EDT ---

REVIEW: https://review.gluster.org/17954 (extras: Turn eager-lock off for gluster-block) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 1 Worker Ant 2017-08-01 22:13:43 EDT
REVIEW: https://review.gluster.org/17955 (extras: Turn eager-lock off for gluster-block) posted (#1) for review on release-3.12 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Worker Ant 2017-08-02 11:02:47 EDT
COMMIT: https://review.gluster.org/17955 committed in release-3.12 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 770fb6d9637f9c45fbcac23b35d2493d90d93a12
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Aug 2 07:22:13 2017 +0530

    extras: Turn eager-lock off for gluster-block
    
    With the current implementation of eager-lock FINODELK is taking so much
    time that cassandra workload times out and errors out. AFR eager-locking
    needs to be changed similar to EC eager-locking to make things work
    as expected. In the interim, it is better to turn it off
    
    This is how the profile looks if eager-lock is turned on:
          0.35     628.26 us      64.00 us  129882.00 us          42278    FXATTROP
         17.45   16500.54 us     212.00 us  375829.00 us          79568       WRITE
         81.76  209862.12 us      15.00 us 1992486.00 us          29318    FINODELK
    
    This is how profile looks if eager-lock is turned off:
          1.87     283.71 us      65.00 us  298970.00 us          68346    FXATTROP
          6.33     199.04 us      13.00 us  373428.00 us         330524    FINODELK
         10.37    3151.47 us      53.00 us 1528484.00 us          34172       FSYNC
         81.31    5110.45 us     270.00 us 1519722.00 us         165244       WRITE
    
     >BUG: 1477404
     >Change-Id: I98026b1ecf30002ddac01be76f375c2e8c0b7838
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    
    BUG: 1477405
    Change-Id: I98026b1ecf30002ddac01be76f375c2e8c0b7838
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: https://review.gluster.org/17955
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-by: Prasanna Kumar Kalever <pkalever@redhat.com>
Comment 3 Shyamsundar 2017-09-05 13:38:10 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.