Bug 147742 - useradd -G corrupts /etc/gshadow line for the group
useradd -G corrupts /etc/gshadow line for the group
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 16:45 EST by john.l.villalovos
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-25 10:41:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fixed maxmem.patch from Mogens Kjaer (mk@crc.dk) (1.63 KB, patch)
2005-02-25 10:40 EST, Peter Vrabec
no flags Details | Diff

  None (edit)
Description john.l.villalovos 2005-02-10 16:45:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

Description of problem:
Doing a useradd -G command and the group line specified becomes corrupted.


Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-56

How reproducible:
Always

Steps to Reproduce:
1.  useradd -G build whack


Actual Results:  Examine /etc/gshadow

Notice the "build" group line appears to be corrupted with the list of users in the group.

build:!::,!,,,,,,!,,,!,,,,,,,,,,whack

Expected Results:  Should be:

build:!::whack

Additional info:
Comment 1 Peter Vrabec 2005-02-18 05:02:14 EST
I can't reproduce it.
Why do u use release 56. I thought there is release #37 in fc3?

$rpm -qi shadow-utils
Name        : shadow-utils                 Relocations: (not relocatable)
Version     : 4.0.3                             Vendor: (none)
Release     : 57                            Build Date: Fri 18 Feb 2005 09:48:26 
# useradd -G rat Dezo
# cat /etc/gshadow | grep Dezo
rat:!::Dezo
Dezo:!::
Comment 2 Peter Vrabec 2005-02-18 10:25:18 EST
I think i have already fount it. There must be a bug somewhere in
shadow-4.0.3-maxmem.patch. Release #57(from devel) doesn't include this patch,
that was the reason it has worked for me.
Comment 3 Peter Vrabec 2005-02-25 10:40:17 EST
Created attachment 111424 [details]
fixed maxmem.patch from Mogens Kjaer (mk@crc.dk)
Comment 4 john.l.villalovos 2005-02-25 13:40:26 EST
Will this be added as an update for Fedora Core 3?  I hope so.

Note You need to log in before you can comment on or make changes to this bug.