Bug 1477461 - running docker containers prevents processes to use real-time scheduling when restarted [rhel-7.4.z]
running docker containers prevents processes to use real-time scheduling when...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: corosync (Show other bugs)
7.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jan Friesse
cluster-qe@redhat.com
: Triaged, ZStream
Depends On: 1476214
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 03:40 EDT by Oneata Mircea Teodor
Modified: 2017-09-05 07:24 EDT (History)
30 users (show)

See Also:
Fixed In Version: corosync-2.4.0-9.el7_4.1
Doc Type: Bug Fix
Doc Text:
Previously, when the corosync service was started or restarted after systemd enabled CPU Accounting, corosync was not able to run with Real Time (RT) scheduling priority. This in some cases reduced the stability of the High Availability (HA) cluster. This update moves corosync to the root CPU cgroup by default and now, corosync can run with Real Time priority as expected.
Story Points: ---
Clone Of: 1476214
Environment:
Last Closed: 2017-09-05 07:24:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch 1 (6.35 KB, patch)
2017-08-02 07:18 EDT, Jan Friesse
no flags Details | Diff
Proposed patch 2 (8.43 KB, patch)
2017-08-02 07:18 EDT, Jan Friesse
no flags Details | Diff

  None (edit)
Description Oneata Mircea Teodor 2017-08-02 03:40:33 EDT
This bug has been copied from bug #1476214 and has been proposed to be backported to 7.4 z-stream (EUS).
Comment 2 Jan Friesse 2017-08-02 07:18 EDT
Created attachment 1308124 [details]
Proposed patch 1
Comment 3 Jan Friesse 2017-08-02 07:18 EDT
Created attachment 1308125 [details]
Proposed patch 2
Comment 7 errata-xmlrpc 2017-09-05 07:24:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2570

Note You need to log in before you can comment on or make changes to this bug.