Bug 1477476 - libreport-plugin-mailx don't respect the EmailFrom/EmailTo settings when write it in '"'
libreport-plugin-mailx don't respect the EmailFrom/EmailTo settings when wri...
Status: NEW
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreport (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: abrt
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 04:01 EDT by Frank Büttner
Modified: 2017-08-02 04:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2017-08-02 04:01:36 EDT
Description of problem:
When using it to send an e-mail the header of the mail contains an incorrect "From"/"To" field.

But the from/to part at the smtp transfer part are ok.
The error happens after the data command.


Version-Release number of selected component (if applicable):
libreport-plugin-mailx-2.1.11-35

How reproducible:
Every time

Steps to Reproduce:
1. let an application crash


Actual results:
The generated email will contain in invalid "From"/"To" field in the header.
From: <"foo@foo.foo"@localhost.localdomain>
To: <"bar@bar.bar" @localhost.localdomain>

But the the smtp part before the data command:
MAIL FROM:<foo@foo.do> SIZE=15023
RCPT TO:<bar@bar.bar> ORCPT=rfc822;bar@bar.bar
DATA


Expected results:
An correct mail header.


Additional info:
/etc/libreport/plugins/mailx.conf:
EmailFrom="foo@foo.foo"
EmailTo="bar@bar.bar"

using:
EmailFrom=foo@foo.foo
EmailTo=bar@bar.bar
will work. But on http://abrt.readthedocs.io/en/latest/examples.html the fields are written with '"'.

Note You need to log in before you can comment on or make changes to this bug.