Bug 1477500 - DR (site to site) - Add cluster name to the VM's OVF
DR (site to site) - Add cluster name to the VM's OVF
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Maor
Elad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 05:34 EDT by Maor
Modified: 2017-12-20 05:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:53:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
ovf (8.92 KB, text/plain)
2017-12-17 12:25 EST, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 82255 master MERGED core: Support cluster name as part of OVF 2017-10-23 15:27 EDT
oVirt gerrit 82829 master POST core: Update cluster name when register a VM 2017-10-23 11:23 EDT
oVirt gerrit 82964 master POST core: Update cluster name when register a Template 2017-10-23 11:23 EDT
oVirt gerrit 83396 master MERGED core: Map cluster with generics 2017-11-09 05:49 EST
oVirt gerrit 83500 master MERGED core: Implement readGeneralData in OvfOvirtReader 2017-11-09 05:50 EST
oVirt gerrit 83501 master MERGED core: Update cluster name in OVF oVirt writer 2017-11-09 05:50 EST

  None (edit)
Description Maor 2017-08-02 05:34:33 EDT
Description of problem:
As part of the disaster recovery scenario a recovered site have pre-configured clusters which might be different than the original site.

The registration process of unregistered VMs/Templates obligates the user to provide a cluster id.

We would like cluster name to the VM/Template OVF.
The idea is that on the recovery process we will take the cluster name from the entity OVF and map it using a predefined mapper of DR tool to the cluster on the secondary site.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Allon Mureinik 2017-11-14 05:29:38 EST
Maor - everything here seems to be merged.
Are we waiting for any other patches, or should this be MODIFIED?
Comment 2 Maor 2017-11-14 06:10:05 EST
(In reply to Allon Mureinik from comment #1)
> Maor - everything here seems to be merged.
> Are we waiting for any other patches, or should this be MODIFIED?

yes, I got some last touch ups but the functionality should be valid
Comment 3 Allon Mureinik 2017-11-19 05:52:44 EST
Setting requires-doc- - we'll document all of the DR improvements together.
Comment 4 Elad 2017-12-17 12:25 EST
Created attachment 1369113 [details]
ovf

VM OVF now contains the cluster name.

<ClusterName>secondary_cluster_1</ClusterName>

OVF attached.

Used:
rhvm-4.2.0.2-0.1.el7.noarch
Comment 5 Sandro Bonazzola 2017-12-20 05:53:09 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.