Bug 1477502 - DR (site to site) - Add template versions to OVF
DR (site to site) - Add template versions to OVF
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.1
: ---
Assigned To: Maor
meital avital
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 05:38 EDT by Maor
Modified: 2017-12-27 18:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-27 18:05:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
ylavi: exception+


Attachments (Terms of Use)

  None (edit)
Description Maor 2017-08-02 05:38:31 EDT
Description of problem:
Add template versions to the entity OVF, so on registration the engine will be able to register the template with its versions

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Lavi 2017-12-27 08:22:44 EST
Would not doing for 4.2 this mean that any VM would break if the templates has versions?
Comment 2 Maor 2017-12-27 18:05:41 EST
template version seems to be part of the OVF after all.
Verified it trough the GUI with success.
Once the storage domain is attached to the setup, we can see two Templates with the same name which exists under the unregistered entities sub tab.
The user should only pick the base volume to be registered and that will cause the Template to be registered with its other version.
Closing this bug as current release.

Note You need to log in before you can comment on or make changes to this bug.