Bug 1477505 - DR (site to site) - External LUN disks which are attached to VM should be part of the VM's OVF
DR (site to site) - External LUN disks which are attached to VM should be par...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Maor
Elad
:
Depends On: 1525989
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 05:42 EDT by Maor
Modified: 2018-01-12 07:57 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Adding the ability to register VMs with external LUN disks Reason: Until now we ignored external LUN disks in VM's OVF. In oVirt 4.2 beta we added the support for those external LUN disks as part of the VM's OVF. With the added external LUN disks, oVirt gains the ability to register those VMs to the engine and add the external LUN disks of those VMs as well. Result: External LUN disks are now part of the VM's OVF and can be added as part of the VM registration. Keep in notice that once there is an existing external LUN disk in the ovirt-engine setup it must be removed before importing the VM, unless the partial_import flag is true. In that case the VM will be registered without the external LUN disk
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-12 07:57:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 82253 master MERGED core: Add support for LUN disks in OVF 2017-10-17 07:46 EDT
oVirt gerrit 82428 master MERGED core: Introduce FullEntityOvfData 2017-10-23 15:27 EDT
oVirt gerrit 82429 master MERGED core: Integrate FEOD with OvfOvirtReader 2017-10-23 15:27 EDT
oVirt gerrit 82430 master MERGED core: Integrate FEOD with OvfOvirtWriter 2017-10-23 15:27 EDT
oVirt gerrit 82783 master POST core: Prevent VM removal on detach with LUN disk 2017-10-23 11:22 EDT
oVirt gerrit 82784 master MERGED webadmin: Fix disks sub tab for LUN disks. 2017-10-23 02:17 EDT
oVirt gerrit 82893 master MERGED core: Add minor fixes for import export 2017-10-18 04:20 EDT
oVirt gerrit 83192 master MERGED core: Remove unneccessery LUN attributes from OVF 2017-11-06 06:41 EST

  None (edit)
Description Maor 2017-08-02 05:42:05 EDT
Description of problem:
The VM's OVF currently indicates disk images which are part of the VM.
The OVF should indicate external LUN disks.
I assume that the file mapping of those disks in the OVF should be using /dev/mapper/xxx-xxx-xxx

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Allon Mureinik 2017-11-14 05:30:01 EST
Maor - everything here seems to be merged.
Are we waiting for any other patches, or should this be MODIFIED?
Comment 2 Allon Mureinik 2017-11-19 05:53:24 EST
This improvement is useful even outside the context of the DR tool. Maor, can you supply some doctext fot this please?
Comment 3 Red Hat Bugzilla Rules Engine 2017-11-21 19:09:15 EST
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.
Comment 4 Elad 2017-12-14 10:50:11 EST
Cannot check with FC due to https://bugzilla.redhat.com/show_bug.cgi?id=1525989
Comment 5 Elad 2018-01-07 08:09:53 EST
VM OVF now includes direct LUNs, also with FC (https://bugzilla.redhat.com/show_bug.cgi?id=1525989#c3).


Used rhvm-4.2.1-0.2.el7.noarch

Note You need to log in before you can comment on or make changes to this bug.