Bug 147751 - binfmt_misc mounted twice
binfmt_misc mounted twice
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 17:25 EST by Ivan Gyurdiev
Modified: 2014-03-16 22:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 14:44:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-02-10 17:25:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
Hi, 

I use the binfmt_misc filesystem. However I've placed it in fstab
where it belongs, next to the other filesystems. That causes it
to be mounted twice, because the initscript mounts it internally
after the fstab scan. This is unfortunate, because it causes
selinux denials.

Can the binfmt_misc filesystem please not be mounted in the rc script.
Instead, can it be put in fstab.


Version-Release number of selected component (if applicable):
initscripts-8.04-1

How reproducible:
Always

Steps to Reproduce:
See summary
  

Additional info:
Comment 1 Bill Nottingham 2005-02-10 17:32:14 EST
Putting it in fstab creates a) one off code in the installer b) excessively
messy code on upgrades.
Comment 2 Ivan Gyurdiev 2005-02-10 19:20:08 EST
Can you elaborate - I don't see the problem yet. Why does binfmt have to be
special than every other filesystem in the distribution that's in fstab.

Comment 3 Bill Nottingham 2005-02-10 23:10:15 EST
Any filesystem that needs to be in fstab needs:

a) anaconda code to write it on install
b) random code in the %post of some package to add it on upgrade

b) is a real mess.
Comment 4 Ivan Gyurdiev 2005-02-10 23:22:36 EST
Well, it seems like the right thing to do for consistency.

On the other hand I have found umount/remount pretty useless for binfmt -
it doesn't clear the registered formats. Is there a way to clear those
without a reboot?

Perhaps you are right - I guess I could just get rid of it from fstab instead,
if that's the right thing to do.

Comment 5 Ivan Gyurdiev 2005-02-19 16:59:41 EST
So... is that WONTFIX, and should I close the bug?
It would still be nicer if it was in fstab, I think.
Comment 6 Bill Nottingham 2005-02-21 14:44:46 EST
Yeah, it's pretty much WONTFIX at this point.

Note You need to log in before you can comment on or make changes to this bug.