Bug 1477531 - Incorrect attribute level rights (ipaallowedtoperform) of service object
Incorrect attribute level rights (ipaallowedtoperform) of service object
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
ipa-qe
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 06:57 EDT by Pavel Vomacka
Modified: 2018-04-10 12:45 EDT (History)
8 users (show)

See Also:
Fixed In Version: ipa-4.5.4-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 12:43:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0918 None None None 2018-04-10 12:45 EDT

  None (edit)
Description Pavel Vomacka 2017-08-02 06:57:15 EDT
Description of problem:
In WebUI tables for "Allowed for retrieve/create keytab" user/host/hostgroups/usergroups on service details page are shown as read-only - it is not possible to add anything. This state is there until the first user/usergroup/host/hostgroup is added over CLI. Then tables become writable. 

Before adding user/usergroup/host/hostgroup in CLI the API response does not contain 'ipaallowedtoperform' in attributelevelrights at all. After that the attribute level right is added into response and WebUI is shown correctly. 


Version-Release number of selected component (if applicable):
ipa-4.5.0-21.el7_4.1

How reproducible:
Always

Steps to Reproduce:
1. Install ipa server
2. Go to WebUI Identity - Services
3. Choose any service
4. Scroll down to 'Allow to retrieve/create keytab'
5. It is not possible to add any user/usergroup/host/hostgroup
6. Open command line and add a user to the particular service
$ ipa service-allow-create-keytab
7. Go back to WebUI 
8. Add button is now not grayed out

Actual results:
step 5

Expected results:
It should be possible to add user/usergroup/host/hostgroup right away, not only after first add.

Additional info:
Comment 2 Petr Vobornik 2017-08-02 12:06:03 EDT
Is this a regression?
Comment 3 Pavel Vomacka 2017-08-03 04:30:46 EDT
It works properly in ipa-4.4.0-12 on RHEL 7.3, so yes.
Comment 5 Pavel Vomacka 2017-08-09 08:14:02 EDT
The bug occurs after upgrade from RHEL7.3 to RHEL7.4, too. Even in case that some data has been already added into those tables before upgrade.
Comment 6 Petr Vobornik 2017-08-18 12:19:28 EDT
Upstream ticket:
https://pagure.io/freeipa/issue/7111
Comment 8 Petr Vobornik 2018-01-09 08:48:47 EST
master:
    cf2d171 WebUI: make keytab tables on service and host pages writable
ipa-4-6:
    b9dc569 WebUI: make keytab tables on service and host pages writable
ipa-4-5:
    4304b80 WebUI: make keytab tables on service and host pages writable
Comment 10 Mohammad Rizwan 2018-01-18 04:37:36 EST
version:
ipa-server-4.5.4-8.el7.x86_64
httpd-2.4.6-80.el7.x86_64

Steps:
1. Install ipa server
2. Go to WebUI Identity - Services
3. Choose any service
4. Scroll down to 'Allow to retrieve/create keytab'
5. It is possible to add any user/usergroup/host/hostgroup

Actual result:
user/usergroup/host/hostgroup is added successfully.

Thus based on above observations, marking the bug verified.
Comment 13 errata-xmlrpc 2018-04-10 12:43:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0918

Note You need to log in before you can comment on or make changes to this bug.