Bug 1477595 - pcsd fails to start "Could not find 'rack-protection' (~> 1.4)"
pcsd fails to start "Could not find 'rack-protection' (~> 1.4)"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pcs (Show other bugs)
27
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Ondrej Mular
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 08:36 EDT by Andrew Price
Modified: 2017-11-10 21:57 EST (History)
7 users (show)

See Also:
Fixed In Version: pcs-0.9.160-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-10 21:57:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch sinatra, rack-protection (2.21 KB, patch)
2017-08-02 09:31 EDT, Jun Aruga
no flags Details | Diff

  None (edit)
Description Andrew Price 2017-08-02 08:36:58 EDT
On a fresh rawhide install with pcs-0.9.159-1.fc27.x86_64 and rubygem-rack-protection-2.0.0-1.fc27.noarch:

Aug 02 13:21:45 rawhide1 systemd[1]: Starting PCS GUI and remote configuration interface...
Aug 02 13:21:46 rawhide1 pcsd[406]: /usr/share/rubygems/rubygems/dependency.rb:310:in `to_specs': Could not find 'rack-protection' (~> 1.4) - did find: [rack-protection-2.0.0] (Gem::MissingSpecVersionError)
Aug 02 13:21:46 rawhide1 pcsd[406]: Checked in 'GEM_PATH=/.gem/ruby:/usr/share/gems:/usr/local/share/gems:/usr/lib/pcsd/vendor/bundle/ruby', execute `gem env` for more information
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/specification.rb:1442:in `block in activate_dependencies'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/specification.rb:1431:in `each'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/specification.rb:1431:in `activate_dependencies'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/specification.rb:1413:in `activate'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/core_ext/kernel_gem.rb:68:in `block in gem'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/core_ext/kernel_gem.rb:67:in `synchronize'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/core_ext/kernel_gem.rb:67:in `gem'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/lib/pcsd/pcsd.rb:1:in `<top (required)>'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:133:in `require'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:133:in `rescue in require'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:40:in `require'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/gems/gems/backports-3.7.0/lib/backports/std_lib.rb:9:in `require_with_backports'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/lib/pcsd/ssl.rb:173:in `<top (required)>'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:133:in `require'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:133:in `rescue in require'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:40:in `require'
Aug 02 13:21:46 rawhide1 pcsd[406]:         from /usr/lib/pcsd/pcsd:15:in `<main>'
Aug 02 13:21:46 rawhide1 systemd[1]: pcsd.service: Main process exited, code=exited, status=1/FAILURE
Aug 02 13:21:46 rawhide1 systemd[1]: Failed to start PCS GUI and remote configuration interface.
Comment 1 Jun Aruga 2017-08-02 09:21:48 EDT
Maybe below code is the reason.

pcs.spec
Source14: https://rubygems.org/downloads/sinatra-1.4.8.gem


You may be able to use rubygem-sinatra-2.x and fedora packages instead of below direct access to gem URL.


```
Source11: https://rubygems.org/downloads/orderedhash-0.0.6.gem
Source12: https://rubygems.org/downloads/rack-1.6.4.gem
  => There is a fedora package.
Source13: https://rubygems.org/downloads/rpam-ruby19-1.2.1.gem
Source14: https://rubygems.org/downloads/sinatra-1.4.8.gem
  => There is a fedora package.
Source15: https://rubygems.org/downloads/sinatra-contrib-1.4.7.gem
Source16: https://rubygems.org/downloads/tilt-2.0.6.gem
  => There is a fedora package.
```
Comment 2 Jun Aruga 2017-08-02 09:31 EDT
Created attachment 1308232 [details]
Patch sinatra, rack-protection

I found "old" patch from my local.
That was when I worked with rubygem-sinatra-2.0, and rubygem-rack-protection-2.0.
I forgot why I did not upload it.
Maybe that might be helpful for you.
Comment 3 Andrew Price 2017-08-03 09:02:37 EDT
(In reply to Jun Aruga from comment #2)
> Created attachment 1308232 [details]
> Patch sinatra, rack-protection
> 
> I found "old" patch from my local.
> That was when I worked with rubygem-sinatra-2.0, and
> rubygem-rack-protection-2.0.
> I forgot why I did not upload it.
> Maybe that might be helpful for you.

I would be happy to try a test package.
Comment 4 Jan Kurik 2017-08-15 04:15:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 5 Jun Aruga 2017-08-15 04:48:19 EDT
> I would be happy to try a test package.

Test package?
What do you mean?
Comment 6 Andrew Price 2017-08-16 05:15:29 EDT
(In reply to Jun Aruga from comment #5)
> Test package?
> What do you mean?

A pcs rpm with a patch added.
Comment 7 Jun Aruga 2017-08-16 08:07:10 EDT
OK. Thanks for the explanation.
I was a little worry if I have to do something for that.
Comment 8 Fedora Update System 2017-10-19 06:18:12 EDT
pcs-0.9.160-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-446a71b4ab
Comment 9 Fedora Update System 2017-10-19 11:24:37 EDT
pcs-0.9.160-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-446a71b4ab
Comment 10 Fedora Update System 2017-11-10 21:57:13 EST
pcs-0.9.160-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.